# CVE-2025-53626: pdfme has Sandbox Escape and Prototype Pollution vulnerabilities in pdfme expression evaluation

> Attackers can execute arbitrary code and modify prototypes via sandbox escape in pdfme's expression evaluation feature.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Jul 2025
- **Updated:** 10 Jul 2025
- **Also known as:** GHSA-54xv-94qv-2gfg

## What is CVE-2025-53626?

CVE-2025-53626 is a medium-severity code injection vulnerability in pdfme, published on 10 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

pdfme is a TypeScript-based PDF generator and React-based UI. The expression evaluation feature in pdfme 5.2.0 to 5.4.0 contains critical vulnerabilities allowing sandbox escape leading to XSS and prototype pollution attacks. This vulnerability is fixed in 5.4.1.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2025-53626?

2 open source packages ship an affected version, including @pdfme/common.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@pdfme/common` | npm | From 5.2.0 | 5.4.1 |
| `@pdfme/common` | npm | From 5.2.0 | 5.4.1 |

## How do I fix CVE-2025-53626?

Upgrade @pdfme/common to 5.4.1 or later.

## Is CVE-2025-53626 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53626 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53626 and fix it if it is affected.

What it is: CVE-2025-53626 is a medium-severity code injection vulnerability in pdfme, published on 10 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53626 exists.

Affected packages and fixed versions:
- @pdfme/common (npm): affected from 5.2.0; fixed in 5.4.1
- @pdfme/common (npm): affected from 5.2.0; fixed in 5.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53626/ (Markdown: https://insights.sbomify.com/CVE-2025-53626/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53626
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53626
- OSV: https://osv.dev/vulnerability/CVE-2025-53626

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53626/
Summaries are generated and may contain mistakes; the official description above is the record.
