CVE-2025-53638 Solady lacks extcodesize validation on implementation in ERC4337Factory

Medium 6.9 Published Updated
Exploited in the wild
Not known
Fix
None listed

What is CVE-2025-53638?

CVE-2025-53638 is a medium-severity vulnerability in Vectorized solady, published on 17 Jul 2025.

Official description

Solady is software that provides Solidity snippets with APIs. Starting in version 0.0.125 and prior to version 0.1.24, when an account is deployed via a proxy, using regular Solidity to call its initialization function may result in a silent failure, if the initialization function does not return a `bool` or some other return data. This is because regular Solidity uses `extcodesize(proxy)` to decide if call succeeds. This is insufficient in the case when the proxy points to an empty implementation. Users should upgrade to Solady v0.1.24 or later to receive a patch. Deploy any affected implementations and their factories on new EVM chains as soon as possible.

Weakness: CWE-754

Which versions are affected by CVE-2025-53638?

How do I fix CVE-2025-53638?

No fix has been published for CVE-2025-53638 yet. Limit exposure of the affected software until one is available.

Is CVE-2025-53638 being exploited?

There is no known exploitation of CVE-2025-53638 in the wild and no public exploit code.

Sources

Also known as GHSA-8xvx-4mvg-m9v8.

Is CVE-2025-53638 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free