# CVE-2025-53640: Indico vulnerable to user enumeration via API endpoint

> Attackers can enumerate user details like names and emails via an API endpoint, exposing sensitive information in Indico event management systems.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2025
- **Updated:** 22 Jul 2025
- **Also known as:** GHSA-q28v-664f-q6wj, PYSEC-2026-1462

## What is CVE-2025-53640?

CVE-2025-53640 is a medium-severity vulnerability in indico, published on 14 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. Starting in version 2.2 and prior to version 3.3.7, an endpoint used to display details of users listed in certain fields (such as ACLs) could be misused to dump basic user details (such as name, affiliation and email) in bulk. Version 3.3.7 fixes the issue. Owners of instances that allow everyone to create a user account, who wish to truly restrict access to these user details, should consider restricting user search to managers. As a workaround, it is possible to restrict access to the affected endpoints (e.g. in the webserver config), but doing so would break certain form fields which could no longer show the details of the users listed in those fields, so upgrading instead is highly recommended.

Weakness: CWE-862 (Missing Authorization), CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-53640?

3 open source packages ship an affected version, including indico. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `indico` | PyPI | From 2.2 | 3.3.7 |
| `indico` | PyPI | From 2.2 | 3.3.7 |
| `indico` | PyPI | From 2.2 | 3.3.7 |

Products: Cern Indico.

## How do I fix CVE-2025-53640?

Upgrade indico to 3.3.7 or later.

## Is CVE-2025-53640 being exploited?

There is no known exploitation of CVE-2025-53640 in the wild and no public exploit code.

Public exploit code:

- Broken Object Level Authorization (BOLA) in CERN's Indico leads to authenticated user enumeration. (github_poc): https://github.com/rafaelcorvino1/CVE-2025-53640

## Other vulnerabilities in indico

- [CVE-2026-33046](https://insights.sbomify.com/CVE-2026-33046/): Indico discloses local files resulting in Remote Code Execution through LaTeX injection (high 7.7)
- [CVE-2021-30185](https://insights.sbomify.com/CVE-2021-30185/): Indico Tampering with links (e.g. password reset) in sent emails (high 7.5)
- [CVE-2026-25738](https://insights.sbomify.com/CVE-2026-25738/): Indico has Server-Side Request Forgery (SSRF) in multiple places (medium 6.9)
- [CVE-2026-28352](https://insights.sbomify.com/CVE-2026-28352/): Indico missing access check in event series management API (medium 6.5)
- [CVE-2026-25739](https://insights.sbomify.com/CVE-2026-25739/): Indico affected by Cross-Site-Scripting via material uploads (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53640 and fix it if it is affected.

What it is: CVE-2025-53640 is a medium-severity vulnerability in indico, published on 14 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-53640 in the wild and no public exploit code.

Affected packages and fixed versions:
- indico (PyPI): affected from 2.2; fixed in 3.3.7
- indico (PyPI): affected from 2.2; fixed in 3.3.7
- indico (PyPI): affected from 2.2; fixed in 3.3.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53640/ (Markdown: https://insights.sbomify.com/CVE-2025-53640/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53640
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53640
- OSV: https://osv.dev/vulnerability/CVE-2025-53640

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53640/
Summaries are generated and may contain mistakes; the official description above is the record.
