CVE-2025-53643 AIOHTTP is vulnerable to HTTP Request/Response Smuggling through incorrect parsing of chunked trailer sections
Attackers can bypass firewalls or proxies via HTTP request smuggling when using the pure Python parser or disabling C extensions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-53643?
CVE-2025-53643 is a low-severity vulnerability in aio-libs aiohttp, published on 14 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
AIOHTTP is an asynchronous HTTP client/server framework for asyncio and Python. Prior to version 3.12.14, the Python parser is vulnerable to a request smuggling vulnerability due to not parsing trailer sections of an HTTP request. If a pure Python version of aiohttp is installed (i.e. without the usual C extensions) or AIOHTTP_NO_EXTENSIONS is enabled, then an attacker may be able to execute a request smuggling attack to bypass certain firewalls or proxy protections. Version 3.12.14 contains a patch for this issue.
Weakness: CWE-444
Which versions are affected by CVE-2025-53643?
3 open source packages ship an affected version, including aiohttp. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
aiohttp PyPI | All versions | 3.12.14 |
aiohttp PyPI | All versions | 3.12.14 |
aiohttp PyPI | All versions | 3.12.14 |
Linux distribution packages (9)
python-aiohttp SUSE:Linux Enterprise Module for Public Cloud 15 SP3 | All versions | 3.6.0-150100.3.27.1 |
python-aiohttp SUSE:Linux Enterprise Module for Public Cloud 15 SP4 | All versions | 3.6.0-150100.3.27.1 |
python-aiohttp SUSE:Linux Enterprise Module for Public Cloud 15 SP4 | All versions | 3.9.3-150400.10.33.1 |
python-aiohttp SUSE:Linux Enterprise Module for Public Cloud 15 SP5 | All versions | 3.6.0-150100.3.27.1 |
python-aiohttp SUSE:Linux Enterprise Module for Public Cloud 15 SP6 | All versions | 3.6.0-150100.3.27.1 |
python-aiohttp SUSE:Linux Enterprise Module for Public Cloud 15 SP7 | All versions | 3.6.0-150100.3.27.1 |
python-aiohttp SUSE:Linux Enterprise Module for Python 3 15 SP6 | All versions | 3.9.3-150400.10.33.1 |
python-aiohttp SUSE:Linux Enterprise Module for Python 3 15 SP7 | All versions | 3.9.3-150400.10.33.1 |
python-aiohttp openSUSE:Leap 15.6 | All versions | 3.9.3-150400.10.33.1 |
Products include Aiohttp Aiohttp.
How do I fix CVE-2025-53643?
Upgrade aiohttp to 3.12.14 or later.
Is CVE-2025-53643 being exploited?
There is no known exploitation of CVE-2025-53643 in the wild and no public exploit code.
Other vulnerabilities in aio-libs aiohttp
- CVE-2024-52303 aiohttp memory leak when middleware is enabled when requesting a resource with a non-allowed method
- CVE-2025-69223 AIOHTTP's HTTP Parser auto_decompress feature is vulnerable to zip bomb
- CVE-2024-30251 Denial of service when trying to parse malformed POST requests in aiohttp
- CVE-2023-49081 aiohttp's ClientSession is vulnerable to CRLF injection via version
- CVE-2026-22815 AIOHTTP: Uncapped memory usage possible through aiohttp allowing unlimited trailer headers
Sources
Also known as AZL-65252, AZL-65256, CLEANSTART-2026-DC28544, CLEANSTART-2026-QB85343, CLSA-2026-1789379698, DEBIAN-CVE-2025-53643 and 8 more.