# CVE-2025-53643: AIOHTTP is vulnerable to HTTP Request/Response Smuggling through incorrect parsing of chunked trailer sections

> Attackers can bypass firewalls or proxies via HTTP request smuggling when using the pure Python parser or disabling C extensions.

- **Severity:** Low 1.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2025
- **Updated:** 15 Jul 2025
- **Also known as:** AZL-65252, AZL-65256, CLEANSTART-2026-DC28544, CLEANSTART-2026-QB85343, CLSA-2026-1789379698, DEBIAN-CVE-2025-53643, ECHO-1e61-9041-ea81, GHSA-9548-qrrj-x5pj, MINI-gg4p-x955-4v3f, PYSEC-2026-1104, ROOT-APP-PYPI-CVE-2025-53643, SUSE-SU-2025:03057-1, SUSE-SU-2025:03201-1, UBUNTU-CVE-2025-53643

## What is CVE-2025-53643?

CVE-2025-53643 is a low-severity vulnerability in aio-libs aiohttp, published on 14 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

AIOHTTP is an asynchronous HTTP client/server framework for asyncio and Python. Prior to version 3.12.14, the Python parser is vulnerable to a request smuggling vulnerability due to not parsing trailer sections of an HTTP request. If a pure Python version of aiohttp is installed (i.e. without the usual C extensions) or AIOHTTP_NO_EXTENSIONS is enabled, then an attacker may be able to execute a request smuggling attack to bypass certain firewalls or proxy protections. Version 3.12.14 contains a patch for this issue.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2025-53643?

3 open source packages ship an affected version, including aiohttp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aiohttp` | PyPI | All versions | 3.12.14 |
| `aiohttp` | PyPI | All versions | 3.12.14 |
| `aiohttp` | PyPI | All versions | 3.12.14 |
| `python-aiohttp` | SUSE:Linux Enterprise Module for Public Cloud 15 SP3 | All versions | 3.6.0-150100.3.27.1 |
| `python-aiohttp` | SUSE:Linux Enterprise Module for Public Cloud 15 SP4 | All versions | 3.6.0-150100.3.27.1 |
| `python-aiohttp` | SUSE:Linux Enterprise Module for Public Cloud 15 SP4 | All versions | 3.9.3-150400.10.33.1 |
| `python-aiohttp` | SUSE:Linux Enterprise Module for Public Cloud 15 SP5 | All versions | 3.6.0-150100.3.27.1 |
| `python-aiohttp` | SUSE:Linux Enterprise Module for Public Cloud 15 SP6 | All versions | 3.6.0-150100.3.27.1 |
| `python-aiohttp` | SUSE:Linux Enterprise Module for Public Cloud 15 SP7 | All versions | 3.6.0-150100.3.27.1 |
| `python-aiohttp` | SUSE:Linux Enterprise Module for Python 3 15 SP6 | All versions | 3.9.3-150400.10.33.1 |
| `python-aiohttp` | SUSE:Linux Enterprise Module for Python 3 15 SP7 | All versions | 3.9.3-150400.10.33.1 |
| `python-aiohttp` | openSUSE:Leap 15.6 | All versions | 3.9.3-150400.10.33.1 |

Products: Aiohttp Aiohttp.

## How do I fix CVE-2025-53643?

Upgrade aiohttp to 3.12.14 or later.

## Is CVE-2025-53643 being exploited?

There is no known exploitation of CVE-2025-53643 in the wild and no public exploit code.

## Other vulnerabilities in aio-libs aiohttp

- [CVE-2024-52303](https://insights.sbomify.com/CVE-2024-52303/): aiohttp memory leak when middleware is enabled when requesting a resource with a non-allowed method (high 8.7)
- [CVE-2025-69223](https://insights.sbomify.com/CVE-2025-69223/): AIOHTTP's HTTP Parser auto_decompress feature is vulnerable to zip bomb (high 7.5)
- [CVE-2024-30251](https://insights.sbomify.com/CVE-2024-30251/): Denial of service when trying to parse malformed POST requests in aiohttp (high 7.5)
- [CVE-2023-49081](https://insights.sbomify.com/CVE-2023-49081/): aiohttp's ClientSession is vulnerable to CRLF injection via version (high 7.2)
- [CVE-2026-22815](https://insights.sbomify.com/CVE-2026-22815/): AIOHTTP: Uncapped memory usage possible through aiohttp allowing unlimited trailer headers (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53643 and fix it if it is affected.

What it is: CVE-2025-53643 is a low-severity vulnerability in aio-libs aiohttp, published on 14 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-53643 in the wild and no public exploit code.

Affected packages and fixed versions:
- aiohttp (PyPI): affected all versions; fixed in 3.12.14
- aiohttp (PyPI): affected all versions; fixed in 3.12.14
- aiohttp (PyPI): affected all versions; fixed in 3.12.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53643/ (Markdown: https://insights.sbomify.com/CVE-2025-53643/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53643
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53643
- OSV: https://osv.dev/vulnerability/CVE-2025-53643

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53643/
Summaries are generated and may contain mistakes; the official description above is the record.
