CVE-2025-53828 SharePoint for ownCloud 10 is vulnerable to Server-Side Request Forgery (SSRF)

High 8.5 Published Updated

An attacker with admin privileges can exploit an SSRF vulnerability in the SharePoint plugin to execute arbitrary code on the ownCloud server.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-53828?

CVE-2025-53828 is a high-severity server-side request forgery vulnerability in owncloud SharePoint, published on 6 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

SharePoint for ownCloud is an application for using SharePoint with the file storage, synchronization, and sharing application ownCloud Classic. In SharePoint for ownCloud prior to version 0.4.1, which corresponds to ownCloud 10 prior to 10.15.3, an attacker with administrative privileges can use a SSRF vulnerability in the SharePoint app to execute arbitrary code on the system. Upgrade ownCloud 10 to version 10.15.3 or later to receive SharePoint for ownCloud 0.4.1, the fixed version.

Weakness: CWE-918

Which versions are affected by CVE-2025-53828?

How do I fix CVE-2025-53828?

No fix has been published for CVE-2025-53828 yet. Limit exposure of the affected software until one is available.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2025-53828 being exploited?

There is no known exploitation of CVE-2025-53828 in the wild and no public exploit code.

Sources

Is CVE-2025-53828 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free