{"answers":{"affected":"2 open source packages ship an affected version, including binarytorch/larecipe.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53833 exists.","fix":"Upgrade binarytorch/larecipe to 2.8.1 or later.","what":"CVE-2025-53833 is a critical code injection vulnerability in saleem-hadad larecipe, published on 14 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-53833 and fix it if it is affected.\n\nWhat it is: CVE-2025-53833 is a critical code injection vulnerability in saleem-hadad larecipe, published on 14 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53833 exists.\n\nAffected packages and fixed versions:\n- binarytorch/larecipe (Packagist): affected all versions; fixed in 2.8.1\n- binarytorch/larecipe (Packagist): affected all versions; fixed in 2.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-53833/ (Markdown: https://insights.sbomify.com/CVE-2025-53833/index.md)","id":"CVE-2025-53833","markdown":"https://insights.sbomify.com/CVE-2025-53833/index.md","name":"CVE-2025-53833","record":{"aliases":["GHSA-jv7x-xhv2-p5v2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"Laravel documentation package","requires_auth":"none","summary":"Attackers can execute arbitrary code via Server-Side Template Injection in LaRecipe, potentially escalating privileges on the server.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-1336","name":"Improper Neutralization of Special Elements Used in a Template Engine"}],"description":"LaRecipe is an application that allows users to create documentation with Markdown inside a Laravel app. Versions prior to 2.8.1 are vulnerable to Server-Side Template Injection (SSTI), which could potentially lead to Remote Code Execution (RCE) in vulnerable configurations. Attackers could execute arbitrary commands on the server, access sensitive environment variables, and/or escalate access depending on server configuration. Users are strongly advised to upgrade to version v2.8.1 or later to receive a patch.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":"2025-07-16","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":1,"refs":[{"date":"2025-07-16T05:45:41Z","kind":"github_poc","ref":"https://github.com/iQingshan/Blackash-CVE-2025-53833","stars":0,"title":"CVE-2025-53833"},{"date":null,"kind":"nuclei","ref":"http/cves/2025/CVE-2025-53833.yaml","stars":null,"title":"LaRecipe \u003c 2.8.1 Remote Code Execution via SSTI"}],"tier":"weaponised"},"has_fix":true,"headline":"LaRecipe is vulnerable to Server-Side Template Injection attacks","id":"CVE-2025-53833","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"Caido Toast Vulnerable to Reflected Cross-site Scripting","id":"CVE-2025-53834"},"packages":[{"ecosystem":"Packagist","fixed":["2.8.1"],"introduced":["0"],"last_affected":[],"package":"binarytorch/larecipe","purl":null,"source":"GHSA-jv7x-xhv2-p5v2"},{"ecosystem":"Packagist","fixed":["2.8.1"],"introduced":["0"],"last_affected":[],"package":"binarytorch/larecipe","purl":"pkg:composer/binarytorch/larecipe","source":"GHSA-jv7x-xhv2-p5v2"}],"prev":{"headline":"@translated/lara-mcp vulnerable to command injection in import_tmx tool","id":"CVE-2025-53832"},"products":["larecipe"],"published":"2025-07-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-07-15","vendors":["saleem-hadad"]},"summary":"Attackers can execute arbitrary code via Server-Side Template Injection in LaRecipe, potentially escalating privileges on the server.","url":"https://insights.sbomify.com/CVE-2025-53833/"}