# CVE-2025-53833: LaRecipe is vulnerable to Server-Side Template Injection attacks

> Attackers can execute arbitrary code via Server-Side Template Injection in LaRecipe, potentially escalating privileges on the server.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2025
- **Updated:** 15 Jul 2025
- **Also known as:** GHSA-jv7x-xhv2-p5v2

## What is CVE-2025-53833?

CVE-2025-53833 is a critical code injection vulnerability in saleem-hadad larecipe, published on 14 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

LaRecipe is an application that allows users to create documentation with Markdown inside a Laravel app. Versions prior to 2.8.1 are vulnerable to Server-Side Template Injection (SSTI), which could potentially lead to Remote Code Execution (RCE) in vulnerable configurations. Attackers could execute arbitrary commands on the server, access sensitive environment variables, and/or escalate access depending on server configuration. Users are strongly advised to upgrade to version v2.8.1 or later to receive a patch.

Weakness: CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2025-53833?

2 open source packages ship an affected version, including binarytorch/larecipe.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `binarytorch/larecipe` | Packagist | All versions | 2.8.1 |
| `binarytorch/larecipe` | Packagist | All versions | 2.8.1 |

## How do I fix CVE-2025-53833?

Upgrade binarytorch/larecipe to 2.8.1 or later.

## Is CVE-2025-53833 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53833 exists.

Public exploit code:

- CVE-2025-53833 (github_poc): https://github.com/iQingshan/Blackash-CVE-2025-53833
- LaRecipe < 2.8.1 Remote Code Execution via SSTI (nuclei): http/cves/2025/CVE-2025-53833.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53833 and fix it if it is affected.

What it is: CVE-2025-53833 is a critical code injection vulnerability in saleem-hadad larecipe, published on 14 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53833 exists.

Affected packages and fixed versions:
- binarytorch/larecipe (Packagist): affected all versions; fixed in 2.8.1
- binarytorch/larecipe (Packagist): affected all versions; fixed in 2.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53833/ (Markdown: https://insights.sbomify.com/CVE-2025-53833/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53833
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53833
- OSV: https://osv.dev/vulnerability/CVE-2025-53833

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53833/
Summaries are generated and may contain mistakes; the official description above is the record.
