CVE-2025-53835 XWiki Rendering is vulnerable to XSS attacks through insecure XHTML syntax

Critical 9.1 Published Updated

Attackers can inject arbitrary JavaScript via XHTML syntax in editable documents, leading to XSS and potential account takeover.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-53835?

CVE-2025-53835 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 14 Jul 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

XWiki Rendering is a generic rendering system that converts textual input in a given syntax (wiki syntax, HTML, etc) into another syntax (XHTML, etc). Starting in version 5.4.5 and prior to version 14.10, the XHTML syntax depended on the `xdom+xml/current` syntax which allows the creation of raw blocks that permit the insertion of arbitrary HTML content including JavaScript. This allows XSS attacks for users who can edit a document like their user profile (enabled by default). This has been fixed in version 14.10 by removing the dependency on the `xdom+xml/current` syntax from the XHTML syntax. Note that the `xdom+xml` syntax is still vulnerable to this attack. As it's main purpose is testing and its use is quite difficult, this syntax shouldn't be installed or used on a regular wiki. There are no known workarounds apart from upgrading.

Weakness: CWE-80, CWE-79

Which versions are affected by CVE-2025-53835?

2 open source packages ship an affected version, including org.xwiki.rendering:xwiki-rendering-syntax-xhtml. It affects 1 product.

PackageAffectedFixed in
org.xwiki.rendering:xwiki-rendering-syntax-xhtml MavenFrom 5.4.514.10
org.xwiki.rendering:xwiki-rendering-syntax-xhtml MavenFrom 5.4.514.10

Products include Xwiki Xwiki.

How do I fix CVE-2025-53835?

Upgrade org.xwiki.rendering:xwiki-rendering-syntax-xhtml to 14.10 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-53835 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53835 exists.

All Xwiki Xwiki vulnerabilities

Sources

Also known as GHSA-w3wh-g4m9-783p.

Is CVE-2025-53835 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free