# CVE-2025-53835: XWiki Rendering is vulnerable to XSS attacks through insecure XHTML syntax

> Attackers can inject arbitrary JavaScript via XHTML syntax in editable documents, leading to XSS and potential account takeover.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Jul 2025
- **Updated:** 15 Jul 2025
- **Also known as:** GHSA-w3wh-g4m9-783p

## What is CVE-2025-53835?

CVE-2025-53835 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 14 Jul 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

XWiki Rendering is a generic rendering system that converts textual input in a given syntax (wiki syntax, HTML, etc) into another syntax (XHTML, etc). Starting in version 5.4.5 and prior to version 14.10, the XHTML syntax depended on the `xdom+xml/current` syntax which allows the creation of raw blocks that permit the insertion of arbitrary HTML content including JavaScript. This allows XSS attacks for users who can edit a document like their user profile (enabled by default). This has been fixed in version 14.10 by removing the dependency on the `xdom+xml/current` syntax from the XHTML syntax. Note that the `xdom+xml` syntax is still vulnerable to this attack. As it's main purpose is testing and its use is quite difficult, this syntax shouldn't be installed or used on a regular wiki. There are no known workarounds apart from upgrading.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-53835?

2 open source packages ship an affected version, including org.xwiki.rendering:xwiki-rendering-syntax-xhtml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.rendering:xwiki-rendering-syntax-xhtml` | Maven | From 5.4.5 | 14.10 |
| `org.xwiki.rendering:xwiki-rendering-syntax-xhtml` | Maven | From 5.4.5 | 14.10 |

Products: Xwiki Xwiki.

## How do I fix CVE-2025-53835?

Upgrade org.xwiki.rendering:xwiki-rendering-syntax-xhtml to 14.10 or later.

## Is CVE-2025-53835 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53835 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53835 and fix it if it is affected.

What it is: CVE-2025-53835 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 14 Jul 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53835 exists.

Affected packages and fixed versions:
- org.xwiki.rendering:xwiki-rendering-syntax-xhtml (Maven): affected from 5.4.5; fixed in 14.10
- org.xwiki.rendering:xwiki-rendering-syntax-xhtml (Maven): affected from 5.4.5; fixed in 14.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53835/ (Markdown: https://insights.sbomify.com/CVE-2025-53835/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53835
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53835
- OSV: https://osv.dev/vulnerability/CVE-2025-53835

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53835/
Summaries are generated and may contain mistakes; the official description above is the record.
