{"answers":{"affected":"2 open source packages ship an affected version, including nginx and nginx-gateway. It affects 2 products.","exploited":"There is no known exploitation of CVE-2025-53859 in the wild and no public exploit code.","fix":"Upgrade nginx to 1.29.1 or later.","what":"CVE-2025-53859 is a medium-severity vulnerability in F5 NGINX Open Source, published on 13 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-53859 and fix it if it is affected.\n\nWhat it is: CVE-2025-53859 is a medium-severity vulnerability in F5 NGINX Open Source, published on 13 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-53859 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nginx (Bitnami): affected from 0.7.0; fixed in 1.29.1\n- nginx-gateway (Bitnami): affected from 0.7.0; fixed in 1.29.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-53859/ (Markdown: https://insights.sbomify.com/CVE-2025-53859/index.md)","id":"CVE-2025-53859","markdown":"https://insights.sbomify.com/CVE-2025-53859/index.md","name":"CVE-2025-53859","record":{"aliases":["ALPINE-CVE-2025-53859","AZL-66308","AZL-66311","BELL-CVE-2025-53859","BIT-nginx-2025-53859","BIT-nginx-gateway-2025-53859","DEBIAN-CVE-2025-53859","ECHO-96bd-541e-cce9","GHSA-2qmj-q2xc-85v8","MGASA-2025-0245","MINI-j7rx-2468-6g8x","MINI-mf95-rf28-r2c3","MINI-v38x-24j8-h2jv","MINI-xr88-29g5-j238","OESA-2025-2086","OESA-2025-2087","OESA-2025-2088","OESA-2025-2089","OESA-2025-2090","OESA-2025-2136","UBUNTU-CVE-2025-53859","USN-7715-1","openSUSE-SU-2025:15449-1"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"NGINX mail module","requires_auth":"none","summary":"Unauthenticated attackers can leak arbitrary memory bytes from the SMTP authentication process if specific non-default configurations are enabled.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"f5","cpe":[{"product":"nginx_open_source","vendor":"f5"},{"product":"nginx_plus","vendor":"f5"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"NGINX Open Source and NGINX Plus have a vulnerability in the ngx_mail_smtp_module that might allow an unauthenticated attacker to over-read NGINX SMTP authentication process memory; as a result, the server side may leak arbitrary bytes sent in a request to the authentication server. This issue happens during the NGINX SMTP authentication process and requires the attacker to make preparations against the target system to extract the leaked data. The issue affects NGINX only if (1) it is built with the ngx_mail_smtp_module, (2) the smtp_auth directive is configured with method \"none,\" and (3) the authentication server returns the \"Auth-Wait\" response header.\n\nNote: Software versions which have reached End of Technical Support (EoTS) are not evaluated.","ecosystems":["Bitnami","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"NGINX ngx_mail_smtp_module vulnerability","id":"CVE-2025-53859","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"information_disclosure","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"F5OS-A FIPS HSM vulnerability","id":"CVE-2025-53860"},"packages":[{"ecosystem":"Bitnami","fixed":["1.29.1"],"introduced":["0.7.0"],"last_affected":[],"package":"nginx","purl":"pkg:bitnami/nginx","source":"BIT-nginx-2025-53859"},{"ecosystem":"Bitnami","fixed":["1.29.1"],"introduced":["0.7.0"],"last_affected":[],"package":"nginx-gateway","purl":"pkg:bitnami/nginx-gateway","source":"BIT-nginx-gateway-2025-53859"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.29.1-1.1"],"introduced":["0"],"last_affected":[],"package":"nginx","purl":"pkg:rpm/opensuse/nginx\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15449-1"}],"prev":{"headline":"Cross-site scripting in ChatLuck","id":"CVE-2025-53858"},"products":["NGINX Open Source","NGINX Plus"],"published":"2025-08-13","related":[{"cvss_score":8.8,"headline":"NGINX ngx_http_dav_module vulnerability","id":"CVE-2026-27654","kev_date_added":null,"published":"2026-03-24"},{"cvss_score":8.7,"headline":"NGINX ngx_mail_auth_http_module vulnerability","id":"CVE-2026-27651","kev_date_added":null,"published":"2026-03-24"},{"cvss_score":8.5,"headline":"NGINX ngx_http_mp4_module vulnerability","id":"CVE-2026-27784","kev_date_added":null,"published":"2026-03-24"},{"cvss_score":8.5,"headline":"NGINX ngx_http_mp4_module vulnerability","id":"CVE-2026-32647","kev_date_added":null,"published":"2026-03-24"},{"cvss_score":7.5,"headline":"NGINX HTTP/3 QUIC vulnerability","id":"CVE-2024-24989","kev_date_added":null,"published":"2024-02-14"},{"cvss_score":7.5,"headline":"NGINX HTTP/3 QUIC vulnerability","id":"CVE-2024-24990","kev_date_added":null,"published":"2024-02-14"},{"cvss_score":6.5,"headline":"NGINX HTTP/3 QUIC vulnerability","id":"CVE-2024-32760","kev_date_added":null,"published":"2024-05-29"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["F5"]},"summary":"Unauthenticated attackers can leak arbitrary memory bytes from the SMTP authentication process if specific non-default configurations are enabled.","url":"https://insights.sbomify.com/CVE-2025-53859/"}