# CVE-2025-53859: NGINX ngx_mail_smtp_module vulnerability

> Unauthenticated attackers can leak arbitrary memory bytes from the SMTP authentication process if specific non-default configurations are enabled.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2025
- **Updated:** 4 Nov 2025
- **Also known as:** ALPINE-CVE-2025-53859, AZL-66308, AZL-66311, BELL-CVE-2025-53859, BIT-nginx-2025-53859, BIT-nginx-gateway-2025-53859, DEBIAN-CVE-2025-53859, ECHO-96bd-541e-cce9, GHSA-2qmj-q2xc-85v8, MGASA-2025-0245, MINI-j7rx-2468-6g8x, MINI-mf95-rf28-r2c3, MINI-v38x-24j8-h2jv, MINI-xr88-29g5-j238, OESA-2025-2086, OESA-2025-2087, OESA-2025-2088, OESA-2025-2089, OESA-2025-2090, OESA-2025-2136, UBUNTU-CVE-2025-53859, USN-7715-1, openSUSE-SU-2025:15449-1

## What is CVE-2025-53859?

CVE-2025-53859 is a medium-severity vulnerability in F5 NGINX Open Source, published on 13 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NGINX Open Source and NGINX Plus have a vulnerability in the ngx_mail_smtp_module that might allow an unauthenticated attacker to over-read NGINX SMTP authentication process memory; as a result, the server side may leak arbitrary bytes sent in a request to the authentication server. This issue happens during the NGINX SMTP authentication process and requires the attacker to make preparations against the target system to extract the leaked data. The issue affects NGINX only if (1) it is built with the ngx_mail_smtp_module, (2) the smtp_auth directive is configured with method "none," and (3) the authentication server returns the "Auth-Wait" response header.

Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2025-53859?

2 open source packages ship an affected version, including nginx and nginx-gateway. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nginx` | Bitnami | From 0.7.0 | 1.29.1 |
| `nginx-gateway` | Bitnami | From 0.7.0 | 1.29.1 |
| `nginx` | openSUSE:Tumbleweed | All versions | 1.29.1-1.1 |

Products: F5 Nginx Open Source, F5 Nginx Plus.

## How do I fix CVE-2025-53859?

Upgrade nginx to 1.29.1 or later.

## Is CVE-2025-53859 being exploited?

There is no known exploitation of CVE-2025-53859 in the wild and no public exploit code.

## Other vulnerabilities in F5 NGINX Open Source

- [CVE-2026-27654](https://insights.sbomify.com/CVE-2026-27654/): NGINX ngx_http_dav_module vulnerability (high 8.8)
- [CVE-2026-27651](https://insights.sbomify.com/CVE-2026-27651/): NGINX ngx_mail_auth_http_module vulnerability (high 8.7)
- [CVE-2026-27784](https://insights.sbomify.com/CVE-2026-27784/): NGINX ngx_http_mp4_module vulnerability (high 8.5)
- [CVE-2026-32647](https://insights.sbomify.com/CVE-2026-32647/): NGINX ngx_http_mp4_module vulnerability (high 8.5)
- [CVE-2024-24989](https://insights.sbomify.com/CVE-2024-24989/): NGINX HTTP/3 QUIC vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53859 and fix it if it is affected.

What it is: CVE-2025-53859 is a medium-severity vulnerability in F5 NGINX Open Source, published on 13 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-53859 in the wild and no public exploit code.

Affected packages and fixed versions:
- nginx (Bitnami): affected from 0.7.0; fixed in 1.29.1
- nginx-gateway (Bitnami): affected from 0.7.0; fixed in 1.29.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53859/ (Markdown: https://insights.sbomify.com/CVE-2025-53859/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53859
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53859
- OSV: https://osv.dev/vulnerability/CVE-2025-53859

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53859/
Summaries are generated and may contain mistakes; the official description above is the record.
