CVE-2025-53887 Directus's exact version number is exposed by the OpenAPI Spec

Medium 5.3 Published Updated

Unauthenticated attackers can retrieve the exact Directus version via the OpenAPI spec endpoint, facilitating targeted vulnerability research.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-53887?

CVE-2025-53887 is a medium-severity vulnerability in Monospace Directus, published on 14 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Directus is a real-time API and App dashboard for managing SQL database content. Starting in version 9.0.0 and prior to version 11.9.0, the exact Directus version number is incorrectly being used as OpenAPI Spec version this means that it is being exposed by the `/server/specs/oas` endpoint without authentication. With the exact version information a malicious attacker can look for known vulnerabilities in Directus core or any of its shipped dependencies in that specific running version. Version 11.9.0 fixes the issue.

Weakness: CWE-200

Which versions are affected by CVE-2025-53887?

2 open source packages ship an affected version, including directus. It affects 1 product.

PackageAffectedFixed in
directus npmAll versions11.9.0
directus npmAll versions11.9.0

Products include Monospace Directus.

How do I fix CVE-2025-53887?

Upgrade directus to 11.9.0 or later.

Is CVE-2025-53887 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53887 exists.

Public exploit code: 1 Nuclei template and 1 proofs of concept on GitHub.

All Monospace Directus vulnerabilities

Sources

Also known as GHSA-rmjh-cf9q-pv7q.

Is CVE-2025-53887 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free