# CVE-2025-53889: Directus missing permission checks for manual trigger Flows

> Attackers can execute manual trigger Flows without authentication or proper permissions, potentially accessing data or performing actions on their behalf.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2025
- **Updated:** 15 Jul 2025
- **Also known as:** GHSA-7cvf-pxgp-42fc

## What is CVE-2025-53889?

CVE-2025-53889 is a medium-severity missing authorization vulnerability in Monospace Directus, published on 14 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Directus is a real-time API and App dashboard for managing SQL database content. Starting in version 9.12.0 and prior to version 11.9.0, Directus Flows with a manual trigger are not validating whether the user triggering the Flow has permissions to the items provided as payload to the Flow. Depending on what the Flow is set up to do this can lead to the Flow executing potential tasks on the attacker's behalf without authenticating. Bad actors could execute the manual trigger Flows without authentication, or access rights to the said collection(s) or item(s). Users with manual trigger Flows configured are impacted as these endpoints do not currently validate if the user has read access to `directus_flows` or to the relevant collection/items. The manual trigger Flows should have tighter security requirements as compared to webhook Flows where users are expected to perform do their own checks. Version 11.9.0 fixes the issue. As a workaround, implement permission checks for read access to Flows and read access to relevant collection/items.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2025-53889?

2 open source packages ship an affected version, including directus. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `directus` | npm | All versions | 11.9.0 |
| `directus` | npm | All versions | 11.9.0 |

Products: Monospace Directus.

## How do I fix CVE-2025-53889?

Upgrade directus to 11.9.0 or later.

## Is CVE-2025-53889 being exploited?

There is no known exploitation of CVE-2025-53889 in the wild and no public exploit code.

## Other vulnerabilities in Monospace Directus

- [CVE-2022-26969](https://insights.sbomify.com/CVE-2022-26969/): Insecure default value for CORS configuration (critical 9.8)
- [CVE-2025-55746](https://insights.sbomify.com/CVE-2025-55746/): Directus allows unauthenticated file upload and file modification due to lacking input sanitization (critical 9.3)
- [CVE-2026-35408](https://insights.sbomify.com/CVE-2026-35408/): Directus is Missing Cross-Origin Opener Policy (high 8.7)
- [CVE-2026-61836](https://insights.sbomify.com/CVE-2026-61836/): Directus: Authorization-dependent response served from unsegmented cache key (high 8.6)
- [CVE-2025-30353](https://insights.sbomify.com/CVE-2025-30353/): Directus's webhook trigger flows can leak sensitive data (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53889 and fix it if it is affected.

What it is: CVE-2025-53889 is a medium-severity missing authorization vulnerability in Monospace Directus, published on 14 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-53889 in the wild and no public exploit code.

Affected packages and fixed versions:
- directus (npm): affected all versions; fixed in 11.9.0
- directus (npm): affected all versions; fixed in 11.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53889/ (Markdown: https://insights.sbomify.com/CVE-2025-53889/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53889
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53889
- OSV: https://osv.dev/vulnerability/CVE-2025-53889

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53889/
Summaries are generated and may contain mistakes; the official description above is the record.
