# CVE-2025-53890: pyLoad vulnerable to remote code execution through js2py onCaptchaResult

> Unauthenticated attackers can execute arbitrary code via unsafe JavaScript evaluation in pyLoad's CAPTCHA processing, leading to full system compromise.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2025
- **Updated:** 15 Jul 2025
- **Also known as:** GHSA-8w3f-4r8f-pf53, PYSEC-2026-496

## What is CVE-2025-53890?

CVE-2025-53890 is a critical code injection vulnerability in pyload, published on 14 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

pyload is an open-source Download Manager written in pure Python. An unsafe JavaScript evaluation vulnerability in pyLoad’s CAPTCHA processing code allows unauthenticated remote attackers to execute arbitrary code in the client browser and potentially the backend server. Exploitation requires no user interaction or authentication and can result in session hijacking, credential theft, and full system remote code execution. Commit 909e5c97885237530d1264cfceb5555870eb9546, the patch for the issue, is included in version 0.5.0b3.dev89.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2025-53890?

3 open source packages ship an affected version, including pyload-ng.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyload-ng` | PyPI | All versions | 0.20 |
| `pyload-ng` | PyPI | All versions | 0.20 |
| `pyload-ng` | PyPI | All versions | 0.20 |

## How do I fix CVE-2025-53890?

Upgrade pyload-ng to 0.20 or later.

## Is CVE-2025-53890 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53890 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53890 and fix it if it is affected.

What it is: CVE-2025-53890 is a critical code injection vulnerability in pyload, published on 14 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-53890 exists.

Affected packages and fixed versions:
- pyload-ng (PyPI): affected all versions; fixed in 0.20
- pyload-ng (PyPI): affected all versions; fixed in 0.20
- pyload-ng (PyPI): affected all versions; fixed in 0.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53890/ (Markdown: https://insights.sbomify.com/CVE-2025-53890/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53890
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53890
- OSV: https://osv.dev/vulnerability/CVE-2025-53890

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53890/
Summaries are generated and may contain mistakes; the official description above is the record.
