# CVE-2025-53899: Kiteworks MFT is vulnerable to an Incorrectly Specified Destination in a Communication Channel


- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 29 Nov 2025
- **Updated:** 1 Dec 2025

## What is CVE-2025-53899?

CVE-2025-53899 is a high-severity vulnerability in kiteworks security-advisories, published on 29 Nov 2025. 

### Official description

Kiteworks MFT orchestrates end-to-end file transfer workflows. Prior to version 9.1.0, the back-end of Kiteworks MFT is vulnerable to an incorrectly specified destination in a communication channel which allows an attacker with administrative privileges on the system under certain circumstances to intercept upstream communication which could lead to an escalation of privileges. This issue has been patched in version 9.1.0.

Weakness: CWE-941 (Incorrectly Specified Destination in a Communication Channel)

## Which versions are affected by CVE-2025-53899?

It affects 1 product.


Products: Accellion Kiteworks Managed File Transfer.

## How do I fix CVE-2025-53899?

No fix has been published for CVE-2025-53899 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-53899 being exploited?

There is no known exploitation of CVE-2025-53899 in the wild and no public exploit code.

## Other vulnerabilities in kiteworks security-advisories

- [CVE-2025-53896](https://insights.sbomify.com/CVE-2025-53896/): Kiteworks MFT is vulnerable to Insufficient Session Expiration (high 7.1)
- [CVE-2025-53897](https://insights.sbomify.com/CVE-2025-53897/): Kiteworks MFT has a Cross-Site Request Forgery (CSRF) vulnerability (medium 6.8)
- [CVE-2025-53900](https://insights.sbomify.com/CVE-2025-53900/): Kiteworks MFT has a Privilege Defined With Unsafe Actions (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53899 and fix it if it is affected.

What it is: CVE-2025-53899 is a high-severity vulnerability in kiteworks security-advisories, published on 29 Nov 2025. 
Exploitation: There is no known exploitation of CVE-2025-53899 in the wild and no public exploit code.

Affected product: kiteworks security-advisories. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53899/ (Markdown: https://insights.sbomify.com/CVE-2025-53899/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53899
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53899
- OSV: https://osv.dev/vulnerability/CVE-2025-53899

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53899/
Summaries are generated and may contain mistakes; the official description above is the record.
