{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-53900 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-53900 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-53900 is a medium-severity vulnerability in kiteworks security-advisories, published on 29 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-53900 and fix it if it is affected.\n\nWhat it is: CVE-2025-53900 is a medium-severity vulnerability in kiteworks security-advisories, published on 29 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-53900 in the wild and no public exploit code.\n\nAffected product: kiteworks security-advisories. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-53900/ (Markdown: https://insights.sbomify.com/CVE-2025-53900/index.md)","id":"CVE-2025-53900","markdown":"https://insights.sbomify.com/CVE-2025-53900/index.md","name":"CVE-2025-53900","record":{"aliases":[],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Managed File Transfer","requires_auth":"low_privilege","summary":"Authorized users can escalate privileges due to unsafe role definitions in Kiteworks MFT connection management.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"kiteworks_managed_file_transfer","vendor":"accellion"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-267","name":"Privilege Defined With Unsafe Actions"}],"description":"Kiteworks MFT orchestrates end-to-end file transfer workflows. Prior to version 9.1.0, an unfavourable definition of roles and permissions in Kiteworks MFT on managing Connections could lead to unexpected escalation of privileges for authorized users. This issue has been patched in version 9.1.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Kiteworks MFT has a Privilege Defined With Unsafe Actions","id":"CVE-2025-53900","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2025"},"n_packages":0,"n_references":1,"next":{"headline":"Wasmtime has host panic with `fd_renumber` WASIp1 function","id":"CVE-2025-53901"},"packages":[],"prev":{"headline":"Kiteworks MFT is vulnerable to an Incorrectly Specified Destination in a Communication Channel","id":"CVE-2025-53899"},"products":["security-advisories"],"published":"2025-11-29","related":[{"cvss_score":7.2,"headline":"Kiteworks MFT is vulnerable to an Incorrectly Specified Destination in a Communication Channel","id":"CVE-2025-53899","kev_date_added":null,"published":"2025-11-29"},{"cvss_score":7.1,"headline":"Kiteworks MFT is vulnerable to Insufficient Session Expiration","id":"CVE-2025-53896","kev_date_added":null,"published":"2025-11-29"},{"cvss_score":6.8,"headline":"Kiteworks MFT has a Cross-Site Request Forgery (CSRF) vulnerability","id":"CVE-2025-53897","kev_date_added":null,"published":"2025-11-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-12-01","vendors":["kiteworks"]},"summary":"Authorized users can escalate privileges due to unsafe role definitions in Kiteworks MFT connection management.","url":"https://insights.sbomify.com/CVE-2025-53900/"}