CVE-2025-53942 authentik has an insufficient check for account active status during OAuth/SAML authentication
Deactivated users can retain partial access to authorize applications in authentik, bypassing account deactivation controls.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-53942?
CVE-2025-53942 is a high-severity authentication bypass vulnerability in goauthentik authentik, published on 23 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
authentik is an open-source Identity Provider that emphasizes flexibility and versatility, with support for a wide set of protocols. In versions 2025.4.4 and earlier, as well as versions 2025.6.0-rc1 through 2025.6.3, deactivated users who registered through OAuth/SAML or linked their accounts to OAuth/SAML providers can still retain partial access to the system despite their accounts being deactivated. They end up in a half-authenticated state where they cannot access the API but crucially they can authorize applications if they know the URL of the application. To workaround this issue, developers can add an expression policy to the user login stage on the respective authentication flow with the expression of return request.context["pending_user"].is_active. This modification ensures that the return statement only activates the user login stage when the user is active. This issue is fixed in versions authentik 2025.4.4 and 2025.6.4.
Weakness: CWE-269
Which versions are affected by CVE-2025-53942?
4 open source packages ship an affected version, including goauthentik.io and authentik. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
goauthentik.io Go | All versions | None |
goauthentik.io Go | All versions | 0.0.0-20250722122105-7a4c6b9b50f8 |
goauthentik.io Go | All versions | 0.0.0-20250722122105-7a4c6b9b50f8 |
authentik Bitnami | All versions | 2025.4.4, 2025.6.4 |
Products include Goauthentik Authentik.
How do I fix CVE-2025-53942?
Upgrade goauthentik.io to 0.0.0-20250722122105-7a4c6b9b50f8 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2025-53942 being exploited?
There is no known exploitation of CVE-2025-53942 in the wild and no public exploit code.
Other vulnerabilities in goauthentik authentik
- CVE-2026-49448 authentik: SourceStage bypass via empty POST
- CVE-2023-46249 authentik potential installation takeover when default admin user is deleted
- CVE-2022-23555 authentik vulnerable to Improper Authentication via invitation URL token reuse
- CVE-2026-42849 authentik: Reflected XSS in SFE AutosubmitStage allows IDP account takeover
- CVE-2026-25227 authentik affected by Remote Code Execution via Context Key Injection in PropertyMapping Test Endpoint
Sources
Also known as BIT-authentik-2025-53942, GHSA-9g4j-v8w5-7x42, GO-2025-3822.