{"answers":{"affected":"3 open source packages ship an affected version, including chainguard.dev/apko.","exploited":"There is no known exploitation of CVE-2025-53945 in the wild and no public exploit code.","fix":"Upgrade chainguard.dev/apko to 0.29.5 or later.","what":"CVE-2025-53945 is a high-severity vulnerability in chainguard-dev apko, published on 18 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-53945 and fix it if it is affected.\n\nWhat it is: CVE-2025-53945 is a high-severity vulnerability in chainguard-dev apko, published on 18 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-53945 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- chainguard.dev/apko (Go): affected from 0.27.0; fixed in 0.29.5\n- chainguard.dev/apko (Go): affected from 0.27.0; fixed in 0.29.5\n- chainguard.dev/apko (Go): affected from 0.27.0; fixed in 0.29.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-53945/ (Markdown: https://insights.sbomify.com/CVE-2025-53945/index.md)","id":"CVE-2025-53945","markdown":"https://insights.sbomify.com/CVE-2025-53945/index.md","name":"CVE-2025-53945","record":{"aliases":["GHSA-x6ph-r535-3vjw","GO-2025-3816"],"analysis":{"component_type":"container_or_infrastructure","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"OCI container builder","requires_auth":"low_privilege","summary":"Attackers can escalate privileges to root due to incorrect file permissions on critical system files in container images built by apko.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-276","name":"Incorrect Default Permissions"}],"description":"apko allows users to build and publish OCI container images built from apk packages. Starting in version 0.27.0 and prior to version 0.29.5, critical files were inadvertently set to 0666, which could likely be abused for root escalation. Version 0.29.5 contains a fix for the issue.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"apko has incorrect permission (0666) in /etc/ld.so.cache and other files","id":"CVE-2025-53945","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"privilege_escalation","year":"2025"},"n_packages":3,"n_references":5,"next":{"headline":"WeGIA vulnerable to SQL Injection in endpoint profile_paciente.php parameter id_fichamedica","id":"CVE-2025-53946"},"packages":[{"ecosystem":"Go","fixed":["0.29.5"],"introduced":["0.27.0"],"last_affected":[],"package":"chainguard.dev/apko","purl":null,"source":"GHSA-x6ph-r535-3vjw"},{"ecosystem":"Go","fixed":["0.29.5"],"introduced":["0.27.0"],"last_affected":[],"package":"chainguard.dev/apko","purl":"pkg:golang/chainguard.dev/apko","source":"GHSA-x6ph-r535-3vjw"},{"ecosystem":"Go","fixed":["0.29.5"],"introduced":["0.27.0"],"last_affected":[],"package":"chainguard.dev/apko","purl":"pkg:golang/chainguard.dev/apko","source":"GO-2025-3816"}],"prev":{"headline":"AutoGPT Platform Exposes Graph Execution Results via Authorization Gap","id":"CVE-2025-53944"},"products":["apko"],"published":"2025-07-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-07-22","vendors":["chainguard-dev"]},"summary":"Attackers can escalate privileges to root due to incorrect file permissions on critical system files in container images built by apko.","url":"https://insights.sbomify.com/CVE-2025-53945/"}