# CVE-2025-53945: apko has incorrect permission (0666) in /etc/ld.so.cache and other files

> Attackers can escalate privileges to root due to incorrect file permissions on critical system files in container images built by apko.

- **Severity:** High 7.0 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jul 2025
- **Updated:** 22 Jul 2025
- **Also known as:** GHSA-x6ph-r535-3vjw, GO-2025-3816

## What is CVE-2025-53945?

CVE-2025-53945 is a high-severity vulnerability in chainguard-dev apko, published on 18 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

apko allows users to build and publish OCI container images built from apk packages. Starting in version 0.27.0 and prior to version 0.29.5, critical files were inadvertently set to 0666, which could likely be abused for root escalation. Version 0.29.5 contains a fix for the issue.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2025-53945?

3 open source packages ship an affected version, including chainguard.dev/apko.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `chainguard.dev/apko` | Go | From 0.27.0 | 0.29.5 |
| `chainguard.dev/apko` | Go | From 0.27.0 | 0.29.5 |
| `chainguard.dev/apko` | Go | From 0.27.0 | 0.29.5 |

## How do I fix CVE-2025-53945?

Upgrade chainguard.dev/apko to 0.29.5 or later.

## Is CVE-2025-53945 being exploited?

There is no known exploitation of CVE-2025-53945 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53945 and fix it if it is affected.

What it is: CVE-2025-53945 is a high-severity vulnerability in chainguard-dev apko, published on 18 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-53945 in the wild and no public exploit code.

Affected packages and fixed versions:
- chainguard.dev/apko (Go): affected from 0.27.0; fixed in 0.29.5
- chainguard.dev/apko (Go): affected from 0.27.0; fixed in 0.29.5
- chainguard.dev/apko (Go): affected from 0.27.0; fixed in 0.29.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53945/ (Markdown: https://insights.sbomify.com/CVE-2025-53945/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53945
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53945
- OSV: https://osv.dev/vulnerability/CVE-2025-53945

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53945/
Summaries are generated and may contain mistakes; the official description above is the record.
