CVE-2025-53971 Channel and Team Membership APIs inadvertently allow loss of Member privileges.
Team Admins can improperly demote Team Members to Guests due to missing authorization checks in the scheme roles API.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-53971?
CVE-2025-53971 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 21 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Mattermost versions 10.5.x <= 10.5.8, 9.11.x <= 9.11.17 fail to properly validate authorization for team scheme role modifications which allows Team Admins to demote Team Members to Guests via the PUT /api/v4/teams/team-id/members/user-id/schemeRoles API endpoint.
Weakness: CWE-863
Which versions are affected by CVE-2025-53971?
14 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.9 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.9 |
github.com/mattermost/mattermost-server Go | From 9.11.0 | 9.11.18 |
github.com/mattermost/mattermost-server Go | From 9.11.0 | 9.11.18 |
github.com/mattermost/mattermost-server Go | From 9.11.0+incompatible | 9.11.18+incompatible, 10.5.9+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
8 more packages
github.com/mattermost/mattermost-server/v5 Go | All versions to 5.39.3 | None |
github.com/mattermost/mattermost-server/v5 Go | All versions to 5.39.3 | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions to 6.7.2 | None |
github.com/mattermost/mattermost-server/v6 Go | All versions to 6.7.2 | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250721095846-c602a4a78e1f |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250721095846-c602a4a78e1f |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250721095846-c602a4a78e1f |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-53971?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.5.9, 9.11.18, 9.11.18+incompatible or 10.5.9+incompatible.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-53971 being exploited?
There is no known exploitation of CVE-2025-53971 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-4276-cm8c-788h, GO-2025-3902.