# CVE-2025-53971: Channel and Team Membership APIs inadvertently allow loss of Member privileges.

> Team Admins can improperly demote Team Members to Guests due to missing authorization checks in the scheme roles API.

- **Severity:** Low 3.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Aug 2025
- **Updated:** 21 Aug 2025
- **Also known as:** GHSA-4276-cm8c-788h, GO-2025-3902

## What is CVE-2025-53971?

CVE-2025-53971 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 21 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Mattermost versions 10.5.x <= 10.5.8, 9.11.x <= 9.11.17 fail to properly validate authorization for team scheme role modifications which allows Team Admins to demote Team Members to Guests via the PUT /api/v4/teams/team-id/members/user-id/schemeRoles API endpoint.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-53971?

14 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | From 10.5.0 | 10.5.9 |
| `github.com/mattermost/mattermost-server` | Go | From 10.5.0 | 10.5.9 |
| `github.com/mattermost/mattermost-server` | Go | From 9.11.0 | 9.11.18 |
| `github.com/mattermost/mattermost-server` | Go | From 9.11.0 | 9.11.18 |
| `github.com/mattermost/mattermost-server` | Go | From 9.11.0+incompatible | 9.11.18+incompatible, 10.5.9+incompatible |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions to 5.39.3 | None |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions to 5.39.3 | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions to 6.7.2 | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions to 6.7.2 | None |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250721095846-c602a4a78e1f |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250721095846-c602a4a78e1f |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250721095846-c602a4a78e1f |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2025-53971?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.5.9, 9.11.18, 9.11.18+incompatible or 10.5.9+incompatible.

## Is CVE-2025-53971 being exploited?

There is no known exploitation of CVE-2025-53971 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-53971 and fix it if it is affected.

What it is: CVE-2025-53971 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 21 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-53971 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected from 10.5.0; fixed in 10.5.9
- github.com/mattermost/mattermost-server (Go): affected from 10.5.0; fixed in 10.5.9
- github.com/mattermost/mattermost-server (Go): affected from 9.11.0; fixed in 9.11.18
- github.com/mattermost/mattermost-server (Go): affected from 9.11.0; fixed in 9.11.18
- github.com/mattermost/mattermost-server (Go): affected from 9.11.0+incompatible; fixed in 9.11.18+incompatible, 10.5.9+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions up to 5.39.3; no fix listed
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions up to 5.39.3; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions up to 6.7.2; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions up to 6.7.2; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250721095846-c602a4a78e1f

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-53971/ (Markdown: https://insights.sbomify.com/CVE-2025-53971/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-53971
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-53971
- OSV: https://osv.dev/vulnerability/CVE-2025-53971

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-53971/
Summaries are generated and may contain mistakes; the official description above is the record.
