CVE-2025-54057 Apache SkyWalking: Stored XSS vulnerability
Attackers can inject malicious scripts into Apache SkyWalking, potentially executing code or hijacking user sessions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2025-54057?
CVE-2025-54057 is a medium-severity cross-site scripting vulnerability in Apache SkyWalking, published on 27 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Apache SkyWalking.
This issue affects Apache SkyWalking: <= 10.2.0.
Users are recommended to upgrade to version 10.3.0, which fixes the issue.
Weakness: CWE-80
Which versions are affected by CVE-2025-54057?
2 open source packages ship an affected version, including org.apache.skywalking:apm-webapp. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.skywalking:apm-webapp Maven | All versions to 10.1.0 | None |
org.apache.skywalking:apm-webapp Maven | All versions to 10.1.0 | None |
Products include Apache Skywalking.
How do I fix CVE-2025-54057?
No fix has been published for CVE-2025-54057 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-54057 being exploited?
There is no known exploitation of CVE-2025-54057 in the wild and no public exploit code.
Other vulnerabilities in Apache SkyWalking
Sources
Also known as GHSA-v6x2-4q87-rf82.