# CVE-2025-54057: Apache SkyWalking: Stored XSS vulnerability

> Attackers can inject malicious scripts into Apache SkyWalking, potentially executing code or hijacking user sessions.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 27 Nov 2025
- **Updated:** 13 Apr 2026
- **Also known as:** GHSA-v6x2-4q87-rf82

## What is CVE-2025-54057?

CVE-2025-54057 is a medium-severity cross-site scripting vulnerability in Apache SkyWalking, published on 27 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Apache SkyWalking.

This issue affects Apache SkyWalking: <= 10.2.0.

Users are recommended to upgrade to version 10.3.0, which fixes the issue.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2025-54057?

2 open source packages ship an affected version, including org.apache.skywalking:apm-webapp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.skywalking:apm-webapp` | Maven | All versions to 10.1.0 | None |
| `org.apache.skywalking:apm-webapp` | Maven | All versions to 10.1.0 | None |

Products: Apache Skywalking.

## How do I fix CVE-2025-54057?

No fix has been published for CVE-2025-54057 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-54057 being exploited?

There is no known exploitation of CVE-2025-54057 in the wild and no public exploit code.

## Other vulnerabilities in Apache SkyWalking

- [CVE-2020-13921](https://insights.sbomify.com/CVE-2020-13921/): SQL Injection in Apache SkyWalking (critical 9.8)
- [CVE-2026-30778](https://insights.sbomify.com/CVE-2026-30778/): SkyWalking OAP /debugging/config/dump endpoint may leak sensitive configuration information (high 7.5)
- [CVE-2020-9483](https://insights.sbomify.com/CVE-2020-9483/): SQL injection in Apache SkyWalking (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54057 and fix it if it is affected.

What it is: CVE-2025-54057 is a medium-severity cross-site scripting vulnerability in Apache SkyWalking, published on 27 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-54057 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.skywalking:apm-webapp (Maven): affected all versions up to 10.1.0; no fix listed
- org.apache.skywalking:apm-webapp (Maven): affected all versions up to 10.1.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54057/ (Markdown: https://insights.sbomify.com/CVE-2025-54057/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54057
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54057
- OSV: https://osv.dev/vulnerability/CVE-2025-54057

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54057/
Summaries are generated and may contain mistakes; the official description above is the record.
