# CVE-2025-54059: melange creates SBOM files in APKs with world-writable permissions

> An attacker can tamper with SBOM files in APKs due to world-writable permissions, confusing security scanners or causing denial of service.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jul 2025
- **Updated:** 18 Jul 2025
- **Also known as:** GHSA-5662-cv6m-63wh, GO-2025-3815

## What is CVE-2025-54059?

CVE-2025-54059 is a medium-severity vulnerability in chainguard-dev melange, published on 18 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

melange allows users to build apk packages using declarative pipelines. Starting in version 0.23.0 and prior to version 0.29.5, SBOM files generated by melange in apks had file system permissions mode 666. This potentially allows an unprivileged user to tamper with apk SBOMs on a running image, potentially confusing security scanners. An attacker could also perform a DoS under special circumstances. Version 0.29.5 fixes the issue.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2025-54059?

3 open source packages ship an affected version, including chainguard.dev/melange.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `chainguard.dev/melange` | Go | From 0.23.0 | 0.29.5 |
| `chainguard.dev/melange` | Go | From 0.23.0 | 0.29.5 |
| `chainguard.dev/melange` | Go | From 0.23.0 | 0.29.5 |

## How do I fix CVE-2025-54059?

Upgrade chainguard.dev/melange to 0.29.5 or later.

## Is CVE-2025-54059 being exploited?

There is no known exploitation of CVE-2025-54059 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54059 and fix it if it is affected.

What it is: CVE-2025-54059 is a medium-severity vulnerability in chainguard-dev melange, published on 18 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-54059 in the wild and no public exploit code.

Affected packages and fixed versions:
- chainguard.dev/melange (Go): affected from 0.23.0; fixed in 0.29.5
- chainguard.dev/melange (Go): affected from 0.23.0; fixed in 0.29.5
- chainguard.dev/melange (Go): affected from 0.23.0; fixed in 0.29.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54059/ (Markdown: https://insights.sbomify.com/CVE-2025-54059/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54059
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54059
- OSV: https://osv.dev/vulnerability/CVE-2025-54059

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54059/
Summaries are generated and may contain mistakes; the official description above is the record.
