# CVE-2025-54066: DiracX-Web login page has Open Redirect vulnerability

> Attackers can redirect authenticated users to malicious sites via unvalidated redirect parameters, enabling phishing and credential theft.

- **Severity:** Medium 4.7 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Jul 2025
- **Updated:** 17 Jul 2025
- **Also known as:** GHSA-hfj7-542q-8fvv

## What is CVE-2025-54066?

CVE-2025-54066 is a medium-severity vulnerability in DIRACGrid diracx-web, published on 17 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

DiracX-Web is a web application that provides an interface to interact with the DiracX services. Prior to version 0.1.0-a8, an attacker can forge a request that they can pass to redirect an authenticated user to another arbitrary website. In the login page, DiracX-Web has a `redirect` field which is the location where the server will redirect the user. This URI is not verified, and can be an arbitrary URI. Paired with a parameter pollution, an attacker can hide their malicious URI. This could be used for phishing, and extract new data (such as redirecting to a new "log in" page, and asking another time credentials). Version 0.1.0-a8 fixes this vulnerability.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2025-54066?

2 open source packages ship an affected version, including @dirac-grid/diracx-web-components.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@dirac-grid/diracx-web-components` | npm | All versions | 0.1.0-a8 |
| `@dirac-grid/diracx-web-components` | npm | All versions | 0.1.0-a8 |

## How do I fix CVE-2025-54066?

Upgrade @dirac-grid/diracx-web-components to 0.1.0-a8 or later.

## Is CVE-2025-54066 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54066 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54066 and fix it if it is affected.

What it is: CVE-2025-54066 is a medium-severity vulnerability in DIRACGrid diracx-web, published on 17 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54066 exists.

Affected packages and fixed versions:
- @dirac-grid/diracx-web-components (npm): affected all versions; fixed in 0.1.0-a8
- @dirac-grid/diracx-web-components (npm): affected all versions; fixed in 0.1.0-a8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54066/ (Markdown: https://insights.sbomify.com/CVE-2025-54066/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54066
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54066
- OSV: https://osv.dev/vulnerability/CVE-2025-54066

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54066/
Summaries are generated and may contain mistakes; the official description above is the record.
