# CVE-2025-54070: OpenZeppelin Contracts Bytes's lastIndexOf function with position argument performs out-of-bound memory access on empty buffers


- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 17 Jul 2025
- **Updated:** 17 Jul 2025
- **Also known as:** GHSA-9rcw-c2f9-2j55

## What is CVE-2025-54070?

CVE-2025-54070 is a medium-severity vulnerability in openzeppelin-contracts, published on 17 Jul 2025. 

### Official description

OpenZeppelin Contracts is a library for secure smart contract development. Starting in version 5.2.0 and prior to version 5.4.0, the `lastIndexOf(bytes,byte,uint256)` function of the `Bytes.sol` library may access uninitialized memory when the following two conditions hold: 1) the provided buffer length is empty (i.e. `buffer.length == 0`) and position is not `2**256 - 1` (i.e. `pos != type(uint256).max`). The `pos` argument could be used to access arbitrary data outside of the buffer bounds. This could lead to the operation running out of gas, or returning an invalid index (outside of the empty buffer). Processing this invalid result for accessing the `buffer` would cause a revert under normal conditions. When triggered, the function reads memory at offset `buffer + 0x20 + pos`. If memory at that location (outside the `buffer`) matches the search pattern, the function would return an out of bound index instead of the expected `type(uint256).max`. This creates unexpected behavior where callers receive a valid-looking index pointing outside buffer bounds. Subsequent memory accesses that don't check bounds and use the returned index must carefully review the potential impact depending on their setup. Code relying on this function returning `type(uint256).max` for empty buffers or using the returned index without bounds checking could exhibit undefined behavior. Users should upgrade to version 5.4.0 to receive a patch.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2025-54070?

4 open source packages ship an affected version, including @openzeppelin/contracts and @openzeppelin/contracts-upgradeable.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@openzeppelin/contracts` | npm | From 5.2.0 | 5.4.0 |
| `@openzeppelin/contracts` | npm | From 5.2.0 | 5.4.0 |
| `@openzeppelin/contracts-upgradeable` | npm | From 5.2.0 | 5.4.0 |
| `@openzeppelin/contracts-upgradeable` | npm | From 5.2.0 | 5.4.0 |

## How do I fix CVE-2025-54070?

Upgrade @openzeppelin/contracts to 5.4.0 or later.

## Is CVE-2025-54070 being exploited?

There is no known exploitation of CVE-2025-54070 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54070 and fix it if it is affected.

What it is: CVE-2025-54070 is a medium-severity vulnerability in openzeppelin-contracts, published on 17 Jul 2025. 
Exploitation: There is no known exploitation of CVE-2025-54070 in the wild and no public exploit code.

Affected packages and fixed versions:
- @openzeppelin/contracts (npm): affected from 5.2.0; fixed in 5.4.0
- @openzeppelin/contracts (npm): affected from 5.2.0; fixed in 5.4.0
- @openzeppelin/contracts-upgradeable (npm): affected from 5.2.0; fixed in 5.4.0
- @openzeppelin/contracts-upgradeable (npm): affected from 5.2.0; fixed in 5.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54070/ (Markdown: https://insights.sbomify.com/CVE-2025-54070/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54070
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54070
- OSV: https://osv.dev/vulnerability/CVE-2025-54070

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54070/
Summaries are generated and may contain mistakes; the official description above is the record.
