{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54072 exists.","fix":"No fix has been published for CVE-2025-54072 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-54072 is a high-severity command injection vulnerability in yt-dlp, published on 22 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-54072 and fix it if it is affected.\n\nWhat it is: CVE-2025-54072 is a high-severity command injection vulnerability in yt-dlp, published on 22 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54072 exists.\n\nAffected product: yt-dlp. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-54072/ (Markdown: https://insights.sbomify.com/CVE-2025-54072/index.md)","id":"CVE-2025-54072","markdown":"https://insights.sbomify.com/CVE-2025-54072/index.md","name":"CVE-2025-54072","record":{"aliases":["GHSA-45hg-7f49-5h56"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"yt-dlp downloader","requires_auth":"none","summary":"Attackers can execute arbitrary commands on Windows systems using yt-dlp's --exec option with unsanitized placeholders, requiring user interaction.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"yt-dlp","vendor":"yt-dlp_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"yt-dlp is a feature-rich command-line audio/video downloader. In versions 2025.06.25 and below, when the --exec option is used on Windows with the default placeholder (or {}), insufficient sanitization is applied to the expanded filepath, allowing for remote code execution. This is a bypass of the mitigation for CVE-2024-22423 where the default placeholder and {} were not covered by the new escaping rules. Windows users who are unable to upgrade should avoid using --exec altogether. Instead, the --write-info-json or --dump-json options could be used, with an external script or command line consuming the JSON output. This is fixed in version 2025.07.21.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"yt-dlp allows `--exec` command injection when using placeholder on Windows","id":"CVE-2025-54072","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":0,"n_references":3,"next":{"headline":"mcp-package-docs vulnerable to command injection in several tools","id":"CVE-2025-54073"},"packages":[],"prev":{"headline":"RomM's authenticated arbitrary file write vulnerability can lead to Remote Code Execution","id":"CVE-2025-54071"},"products":["yt-dlp"],"published":"2025-07-22","related":[{"cvss_score":8.8,"headline":"yt-dlp: Arbitrary Command Injection when using the `--netrc-cmd` option","id":"CVE-2026-26331","kev_date_added":null,"published":"2026-02-24"},{"cvss_score":8.4,"headline":"yt-dlp `--exec` command injection when using `%q` in yt-dlp on Windows","id":"CVE-2024-22423","kev_date_added":null,"published":"2024-04-09"},{"cvss_score":8.4,"headline":"yt-dlp command injection when using `%q` in `--exec` on Windows","id":"CVE-2023-40581","kev_date_added":null,"published":"2023-09-25"},{"cvss_score":8.3,"headline":"yt-dlp: Dangerous file type creation via insufficient filename sanitization (Bypass of CVE-2024-38519)","id":"CVE-2026-50023","kev_date_added":null,"published":"2026-06-23"},{"cvss_score":8.3,"headline":"yt-dlp: Arbitrary code execution via manifest downloads with aria2c","id":"CVE-2026-50574","kev_date_added":null,"published":"2026-06-23"},{"cvss_score":7.5,"headline":"yt-dlp: Downstream command injection via improper sanitization of yt-dlp --write-link output","id":"CVE-2026-55404","kev_date_added":null,"published":"2026-07-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-07-23","vendors":["yt-dlp"]},"summary":"Attackers can execute arbitrary commands on Windows systems using yt-dlp's --exec option with unsanitized placeholders, requiring user interaction.","url":"https://insights.sbomify.com/CVE-2025-54072/"}