# CVE-2025-54072: yt-dlp allows `--exec` command injection when using placeholder on Windows

> Attackers can execute arbitrary commands on Windows systems using yt-dlp's --exec option with unsanitized placeholders, requiring user interaction.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 22 Jul 2025
- **Updated:** 23 Jul 2025
- **Also known as:** GHSA-45hg-7f49-5h56

## What is CVE-2025-54072?

CVE-2025-54072 is a high-severity command injection vulnerability in yt-dlp, published on 22 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

yt-dlp is a feature-rich command-line audio/video downloader. In versions 2025.06.25 and below, when the --exec option is used on Windows with the default placeholder (or {}), insufficient sanitization is applied to the expanded filepath, allowing for remote code execution. This is a bypass of the mitigation for CVE-2024-22423 where the default placeholder and {} were not covered by the new escaping rules. Windows users who are unable to upgrade should avoid using --exec altogether. Instead, the --write-info-json or --dump-json options could be used, with an external script or command line consuming the JSON output. This is fixed in version 2025.07.21.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2025-54072?

It affects 1 product.


Products: Yt-Dlp Project Yt-Dlp.

## How do I fix CVE-2025-54072?

No fix has been published for CVE-2025-54072 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-54072 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54072 exists.

## Other vulnerabilities in yt-dlp

- [CVE-2026-26331](https://insights.sbomify.com/CVE-2026-26331/): yt-dlp: Arbitrary Command Injection when using the `--netrc-cmd` option (high 8.8)
- [CVE-2024-22423](https://insights.sbomify.com/CVE-2024-22423/): yt-dlp `--exec` command injection when using `%q` in yt-dlp on Windows (high 8.4)
- [CVE-2023-40581](https://insights.sbomify.com/CVE-2023-40581/): yt-dlp command injection when using `%q` in `--exec` on Windows (high 8.4)
- [CVE-2026-50023](https://insights.sbomify.com/CVE-2026-50023/): yt-dlp: Dangerous file type creation via insufficient filename sanitization (Bypass of CVE-2024-38519) (high 8.3)
- [CVE-2026-50574](https://insights.sbomify.com/CVE-2026-50574/): yt-dlp: Arbitrary code execution via manifest downloads with aria2c (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54072 and fix it if it is affected.

What it is: CVE-2025-54072 is a high-severity command injection vulnerability in yt-dlp, published on 22 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54072 exists.

Affected product: yt-dlp. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54072/ (Markdown: https://insights.sbomify.com/CVE-2025-54072/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54072
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54072
- OSV: https://osv.dev/vulnerability/CVE-2025-54072

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54072/
Summaries are generated and may contain mistakes; the official description above is the record.
