{"answers":{"affected":"2 open source packages ship an affected version, including mcp-package-docs.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54073 exists.","fix":"Upgrade mcp-package-docs to 0.1.28 or later.","what":"CVE-2025-54073 is a high-severity command injection vulnerability in sammcj mcp-package-docs, published on 18 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-54073 and fix it if it is affected.\n\nWhat it is: CVE-2025-54073 is a high-severity command injection vulnerability in sammcj mcp-package-docs, published on 18 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54073 exists.\n\nAffected packages and fixed versions:\n- mcp-package-docs (npm): affected all versions; fixed in 0.1.28\n- mcp-package-docs (npm): affected all versions; fixed in 0.1.28\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-54073/ (Markdown: https://insights.sbomify.com/CVE-2025-54073/index.md)","id":"CVE-2025-54073","markdown":"https://insights.sbomify.com/CVE-2025-54073/index.md","name":"CVE-2025-54073","record":{"aliases":["GHSA-vf9j-h32g-2764"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"MCP server library","requires_auth":"none","summary":"Attackers can execute arbitrary system commands via unsanitized input in mcp-package-docs, leading to remote code execution.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"mcp-package-docs is an MCP (Model Context Protocol) server that provides LLMs with efficient access to package documentation across multiple programming languages and language server protocol (LSP) capabilities. A command injection vulnerability exists in the `mcp-package-docs` MCP Server prior to the fix in commit cb4ad49615275379fd6f2f1cf1ec4731eec56eb9. The vulnerability is caused by the unsanitized use of input parameters within a call to `child_process.exec`, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. The server constructs and executes shell commands using unvalidated user input directly within command-line strings. This introduces the possibility of shell metacharacter injection (`|`, `\u003e`, `\u0026\u0026`, etc.). Commit cb4ad49615275379fd6f2f1cf1ec4731eec56eb9 in version 0.1.27 contains a fix for the issue, but upgrading to 0.1.28 is recommended.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"mcp-package-docs vulnerable to command injection in several tools","id":"CVE-2025-54073","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":2,"n_references":9,"next":{"headline":"Cherry Studio is Vulnerable to OS Command Injection during Connection with a Malicious MCP Server","id":"CVE-2025-54074"},"packages":[{"ecosystem":"npm","fixed":["0.1.28"],"introduced":["0"],"last_affected":[],"package":"mcp-package-docs","purl":null,"source":"GHSA-vf9j-h32g-2764"},{"ecosystem":"npm","fixed":["0.1.28"],"introduced":["0"],"last_affected":[],"package":"mcp-package-docs","purl":"pkg:npm/mcp-package-docs","source":"GHSA-vf9j-h32g-2764"}],"prev":{"headline":"yt-dlp allows `--exec` command injection when using placeholder on Windows","id":"CVE-2025-54072"},"products":["mcp-package-docs"],"published":"2025-07-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-07-22","vendors":["sammcj"]},"summary":"Attackers can execute arbitrary system commands via unsanitized input in mcp-package-docs, leading to remote code execution.","url":"https://insights.sbomify.com/CVE-2025-54073/"}