# CVE-2025-54073: mcp-package-docs vulnerable to command injection in several tools

> Attackers can execute arbitrary system commands via unsanitized input in mcp-package-docs, leading to remote code execution.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Jul 2025
- **Updated:** 22 Jul 2025
- **Also known as:** GHSA-vf9j-h32g-2764

## What is CVE-2025-54073?

CVE-2025-54073 is a high-severity command injection vulnerability in sammcj mcp-package-docs, published on 18 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

mcp-package-docs is an MCP (Model Context Protocol) server that provides LLMs with efficient access to package documentation across multiple programming languages and language server protocol (LSP) capabilities. A command injection vulnerability exists in the `mcp-package-docs` MCP Server prior to the fix in commit cb4ad49615275379fd6f2f1cf1ec4731eec56eb9. The vulnerability is caused by the unsanitized use of input parameters within a call to `child_process.exec`, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. The server constructs and executes shell commands using unvalidated user input directly within command-line strings. This introduces the possibility of shell metacharacter injection (`|`, `>`, `&&`, etc.). Commit cb4ad49615275379fd6f2f1cf1ec4731eec56eb9 in version 0.1.27 contains a fix for the issue, but upgrading to 0.1.28 is recommended.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2025-54073?

2 open source packages ship an affected version, including mcp-package-docs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mcp-package-docs` | npm | All versions | 0.1.28 |
| `mcp-package-docs` | npm | All versions | 0.1.28 |

## How do I fix CVE-2025-54073?

Upgrade mcp-package-docs to 0.1.28 or later.

## Is CVE-2025-54073 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54073 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54073 and fix it if it is affected.

What it is: CVE-2025-54073 is a high-severity command injection vulnerability in sammcj mcp-package-docs, published on 18 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54073 exists.

Affected packages and fixed versions:
- mcp-package-docs (npm): affected all versions; fixed in 0.1.28
- mcp-package-docs (npm): affected all versions; fixed in 0.1.28

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54073/ (Markdown: https://insights.sbomify.com/CVE-2025-54073/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54073
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54073
- OSV: https://osv.dev/vulnerability/CVE-2025-54073

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54073/
Summaries are generated and may contain mistakes; the official description above is the record.
