# CVE-2025-54080: Exiv2 Segmentation Faults in Exiv2::EpsImage::writeMetadata() via crafted EPS file

> An out-of-bounds read in Exiv2 allows attackers to cause a denial of service via a crafted EPS file during metadata writing.

- **Severity:** Low 1.8 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Aug 2025
- **Updated:** 29 Aug 2025
- **Also known as:** AZL-66711, AZL-66764, CLSA-2025-1766499581, CLSA-2025-1766500438, DEBIAN-CVE-2025-54080, GHSA-496f-x7cq-cq39, JLSEC-2026-1314, OESA-2025-2113, OESA-2025-2114, OESA-2025-2115, PYSEC-2026-1354

## What is CVE-2025-54080?

CVE-2025-54080 is a low-severity denial of service vulnerability in Exiv2 Exiv2, published on 29 Aug 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Exiv2 is a C++ library and a command-line utility to read, write, delete and modify Exif, IPTC, XMP and ICC image metadata. An out-of-bounds read was found in Exiv2 versions 0.28.5 and earlier. The out-of-bounds read is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service by crashing Exiv2, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when writing the metadata, which is a less frequently used Exiv2 operation than reading the metadata. The bug is fixed in version 0.28.6.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2025-54080?

3 open source packages ship an affected version, including exiv2 and Exiv2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `exiv2` | PyPI | All versions to 0.17.3 | None |
| `exiv2` | PyPI | All versions to 0.17.3 | None |
| `Exiv2` | PyPI | All versions to 0.17.3 | None |

Products: Exiv2 Exiv2.

## How do I fix CVE-2025-54080?

Upgrade to a fixed version.

## Is CVE-2025-54080 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54080 exists.

## Other vulnerabilities in Exiv2 Exiv2

- [CVE-2023-44398](https://insights.sbomify.com/CVE-2023-44398/): Out-of-bounds write in exiv2 (high 8.8)
- [CVE-2019-9143](https://insights.sbomify.com/CVE-2019-9143/): Denial of service in n/a (high 8.8)
- [CVE-2019-9144](https://insights.sbomify.com/CVE-2019-9144/): Denial of service in n/a (high 8.8)
- [CVE-2018-14046](https://insights.sbomify.com/CVE-2018-14046/): Memory corruption in n/a (high 8.8)
- [CVE-2017-12955](https://insights.sbomify.com/CVE-2017-12955/): Memory corruption in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54080 and fix it if it is affected.

What it is: CVE-2025-54080 is a low-severity denial of service vulnerability in Exiv2 Exiv2, published on 29 Aug 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54080 exists.

Affected packages and fixed versions:
- exiv2 (PyPI): affected all versions up to 0.17.3; no fix listed
- exiv2 (PyPI): affected all versions up to 0.17.3; no fix listed
- Exiv2 (PyPI): affected all versions up to 0.17.3; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54080/ (Markdown: https://insights.sbomify.com/CVE-2025-54080/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54080
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54080
- OSV: https://osv.dev/vulnerability/CVE-2025-54080

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54080/
Summaries are generated and may contain mistakes; the official description above is the record.
