{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5409 exists.","fix":"No fix has been published for CVE-2025-5409 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-5409 is a medium-severity missing authorization vulnerability in Mist Community Edition, published on 1 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-5409 and fix it if it is affected.\n\nWhat it is: CVE-2025-5409 is a medium-severity missing authorization vulnerability in Mist Community Edition, published on 1 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5409 exists.\n\nAffected product: Mist Community Edition. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-5409/ (Markdown: https://insights.sbomify.com/CVE-2025-5409/index.md)","id":"CVE-2025-5409","markdown":"https://insights.sbomify.com/CVE-2025-5409/index.md","name":"CVE-2025-5409","record":{"aliases":["GHSA-2xm6-ff93-jr99"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Mist Community Edition","requires_auth":"none","summary":"Attackers can bypass access controls in the API Token Handler to create tokens, potentially escalating privileges or bypassing security restrictions.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"mist","vendor":"mist"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"},{"id":"CWE-266","name":"Incorrect Privilege Assignment"}],"description":"A vulnerability was found in Mist Community Edition up to 4.7.1. It has been classified as critical. This affects the function create_token of the file src/mist/api/auth/views.py of the component API Token Handler. The manipulation leads to improper access controls. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 4.7.2 is able to address this issue. The identifier of the patch is db10ecb62ac832c1ed4924556d167efb9bc07fad. It is recommended to upgrade the affected component.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Mist Community Edition API Token views.py create_token access control","id":"CVE-2025-5409","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"missing_authorization","year":"2025"},"n_packages":0,"n_references":6,"next":{"headline":"Mist Community Edition middleware.py session_start_response cross-site request forgery","id":"CVE-2025-5410"},"packages":[],"prev":{"headline":"WAVLINK WL-WN576K1 HTTP POST Request login.cgi sys_login buffer overflow","id":"CVE-2025-5408"},"products":["Community Edition"],"published":"2025-06-01","related":[{"cvss_score":5.3,"headline":"Mist Community Edition middleware.py session_start_response cross-site request forgery","id":"CVE-2025-5410","kev_date_added":null,"published":"2025-06-01"},{"cvss_score":5.1,"headline":"Mist Community Edition views.py tag_resources cross site scripting","id":"CVE-2025-5411","kev_date_added":null,"published":"2025-06-01"},{"cvss_score":5.1,"headline":"Mist Community Edition Authentication Endpoint views.py login cross site scripting","id":"CVE-2025-5412","kev_date_added":null,"published":"2025-06-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-02","vendors":["Mist"]},"summary":"Attackers can bypass access controls in the API Token Handler to create tokens, potentially escalating privileges or bypassing security restrictions.","url":"https://insights.sbomify.com/CVE-2025-5409/"}