CVE-2025-54090 Apache HTTP Server: 'RewriteCond expr' always evaluates to true in 2.4.64
A bug in Apache HTTP Server causes RewriteCond expressions to always evaluate as true, potentially bypassing intended access controls or rewrite rules.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-54090?
CVE-2025-54090 is a medium-severity vulnerability in Apache Http Server, published on 23 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A bug in Apache HTTP Server 2.4.64 results in all "RewriteCond expr ..." tests evaluating as "true".
Users are recommended to upgrade to version 2.4.65, which fixes the issue.
Weakness: CWE-253
Which versions are affected by CVE-2025-54090?
1 open source package ship an affected version, including apache. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache Bitnami | From 2.4.64 | 2.4.65 |
Linux distribution packages (1)
apache2 openSUSE:Tumbleweed | All versions | 2.4.65-1.1 |
Products include Apache Http Server.
How do I fix CVE-2025-54090?
Upgrade apache to 2.4.65 or later.
Is CVE-2025-54090 being exploited?
There is no known exploitation of CVE-2025-54090 in the wild and no public exploit code.
Other vulnerabilities in Apache Http Server
Sources
Also known as ALPINE-CVE-2025-54090, AZL-65654, BELL-CVE-2025-54090, BIT-apache-2025-54090, DEBIAN-CVE-2025-54090, GHSA-cjqj-vhhm-xq5x and 2 more.