CVE-2025-5411 Mist Community Edition views.py tag_resources cross site scripting

Medium 5.1 Published Updated

Remote attackers can inject malicious scripts via the tag parameter in Mist Community Edition, potentially compromising user sessions or data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2025-5411?

CVE-2025-5411 is a medium-severity cross-site scripting vulnerability in Mist Community Edition, published on 1 Jun 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A vulnerability was found in Mist Community Edition up to 4.7.1. It has been rated as problematic. This issue affects the function tag_resources of the file src/mist/api/tag/views.py. The manipulation of the argument tag leads to cross site scripting. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 4.7.2 is able to address this issue. The patch is named db10ecb62ac832c1ed4924556d167efb9bc07fad. It is recommended to upgrade the affected component.

Weakness: CWE-94, CWE-79

Which versions are affected by CVE-2025-5411?

It affects 1 product.

Products include Mist Mist.

How do I fix CVE-2025-5411?

No fix has been published for CVE-2025-5411 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-5411 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5411 exists.

Sources

Also known as GHSA-pq7c-p5rc-hf55.

Is CVE-2025-5411 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free