# CVE-2025-54119: ADOdb's sqlite3 driver allows SQL injection


- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 5 Aug 2025
- **Updated:** 3 Nov 2025
- **Also known as:** DEBIAN-CVE-2025-54119, DLA-4340-1, GHSA-vf2r-cxg9-p7rf, UBUNTU-CVE-2025-54119

## What is CVE-2025-54119?

CVE-2025-54119 is a critical vulnerability in ADOdb, published on 5 Aug 2025. 

### Official description

ADOdb is a PHP database class library that provides abstractions for performing queries and managing databases. In versions 5.22.9 and below, improper escaping of a query parameter may allow an attacker to execute arbitrary SQL statements when the code using ADOdb connects to a sqlite3 database and calls the metaColumns(), metaForeignKeys() or metaIndexes() methods with a crafted table name. This is fixed in version 5.22.10. To workaround this issue, only pass controlled data to metaColumns(), metaForeignKeys() and metaIndexes() method's $table parameter.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-54119?

2 open source packages ship an affected version, including adodb/adodb-php.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `adodb/adodb-php` | Packagist | All versions | 5.22.10 |
| `adodb/adodb-php` | Packagist | All versions | 5.22.10 |

## How do I fix CVE-2025-54119?

Upgrade adodb/adodb-php to 5.22.10 or later.

## Is CVE-2025-54119 being exploited?

There is no known exploitation of CVE-2025-54119 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54119 and fix it if it is affected.

What it is: CVE-2025-54119 is a critical vulnerability in ADOdb, published on 5 Aug 2025. 
Exploitation: There is no known exploitation of CVE-2025-54119 in the wild and no public exploit code.

Affected packages and fixed versions:
- adodb/adodb-php (Packagist): affected all versions; fixed in 5.22.10
- adodb/adodb-php (Packagist): affected all versions; fixed in 5.22.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54119/ (Markdown: https://insights.sbomify.com/CVE-2025-54119/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54119
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54119
- OSV: https://osv.dev/vulnerability/CVE-2025-54119

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54119/
Summaries are generated and may contain mistakes; the official description above is the record.
