CVE-2025-5412 Mist Community Edition Authentication Endpoint views.py login cross site scripting

Medium 5.1 Published Updated

Remote attackers can execute arbitrary scripts via the login return_to parameter, potentially compromising user sessions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2025-5412?

CVE-2025-5412 is a medium-severity cross-site scripting vulnerability in Mist Community Edition, published on 1 Jun 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A vulnerability classified as problematic has been found in Mist Community Edition up to 4.7.1. Affected is the function Login of the file src/mist/api/views.py of the component Authentication Endpoint. The manipulation of the argument return_to leads to cross site scripting. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 4.7.2 is able to address this issue. The name of the patch is db10ecb62ac832c1ed4924556d167efb9bc07fad. It is recommended to upgrade the affected component.

Weakness: CWE-94, CWE-79

Which versions are affected by CVE-2025-5412?

It affects 1 product.

Products include Mist Mist.

How do I fix CVE-2025-5412?

No fix has been published for CVE-2025-5412 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-5412 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5412 exists.

Sources

Also known as GHSA-925x-7pw7-xwpm.

Is CVE-2025-5412 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free