# CVE-2025-5412: Mist Community Edition Authentication Endpoint views.py login cross site scripting

> Remote attackers can execute arbitrary scripts via the login return_to parameter, potentially compromising user sessions.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 1 Jun 2025
- **Updated:** 2 Jun 2025
- **Also known as:** GHSA-925x-7pw7-xwpm

## What is CVE-2025-5412?

CVE-2025-5412 is a medium-severity cross-site scripting vulnerability in Mist Community Edition, published on 1 Jun 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability classified as problematic has been found in Mist Community Edition up to 4.7.1. Affected is the function Login of the file src/mist/api/views.py of the component Authentication Endpoint. The manipulation of the argument return_to leads to cross site scripting. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 4.7.2 is able to address this issue. The name of the patch is db10ecb62ac832c1ed4924556d167efb9bc07fad. It is recommended to upgrade the affected component.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-5412?

It affects 1 product.


Products: Mist Mist.

## How do I fix CVE-2025-5412?

No fix has been published for CVE-2025-5412 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-5412 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5412 exists.

## Other vulnerabilities in Mist Community Edition

- [CVE-2025-5409](https://insights.sbomify.com/CVE-2025-5409/): Mist Community Edition API Token views.py create_token access control (medium 6.9)
- [CVE-2025-5410](https://insights.sbomify.com/CVE-2025-5410/): Mist Community Edition middleware.py session_start_response cross-site request forgery (medium 5.3)
- [CVE-2025-5411](https://insights.sbomify.com/CVE-2025-5411/): Mist Community Edition views.py tag_resources cross site scripting (medium 5.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-5412 and fix it if it is affected.

What it is: CVE-2025-5412 is a medium-severity cross-site scripting vulnerability in Mist Community Edition, published on 1 Jun 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-5412 exists.

Affected product: Mist Community Edition. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-5412/ (Markdown: https://insights.sbomify.com/CVE-2025-5412/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-5412
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-5412
- OSV: https://osv.dev/vulnerability/CVE-2025-5412

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-5412/
Summaries are generated and may contain mistakes; the official description above is the record.
