# CVE-2025-54121: Starlette has possible denial-of-service vector when parsing large files in multipart forms

> Attackers can cause denial of service by uploading large files, blocking the main thread and preventing new connections in Starlette applications.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jul 2025
- **Updated:** 22 Jul 2025
- **Also known as:** CLEANSTART-2026-YZ00893, CLSA-2025-1764115957, CLSA-2025-1764288754, DEBIAN-CVE-2025-54121, GHSA-2c2j-9gv5-cj73, MINI-mfg9-9m76-wmxh, PYSEC-2026-1941, ROOT-APP-PYPI-CVE-2025-54121, SUSE-SU-2025:02544-1, UBUNTU-CVE-2025-54121, openSUSE-SU-2025:15381-1

## What is CVE-2025-54121?

CVE-2025-54121 is a medium-severity denial of service vulnerability in encode starlette, published on 21 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Starlette is a lightweight ASGI (Asynchronous Server Gateway Interface) framework/toolkit, designed for building async web services in Python. In versions 0.47.1 and below, when parsing a multi-part form with large files (greater than the default max spool size) starlette will block the main thread to roll the file over to disk. This blocks the event thread which means the application can't accept new connections. The UploadFile code has a minor bug where instead of just checking for self._in_memory, the logic should also check if the additional bytes will cause a rollover. The vulnerability is fixed in version 0.47.2.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-54121?

3 open source packages ship an affected version, including starlette.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `starlette` | PyPI | All versions | 0.47.2 |
| `starlette` | PyPI | All versions | 0.47.2 |
| `starlette` | PyPI | All versions | 0.47.2 |
| `python-starlette` | openSUSE:Leap 15.6 | All versions | 0.35.1-150600.3.6.1 |
| `python-starlette` | openSUSE:Tumbleweed | All versions | 0.47.2-1.1 |

## How do I fix CVE-2025-54121?

Upgrade starlette to 0.47.2 or later.

## Is CVE-2025-54121 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54121 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54121 and fix it if it is affected.

What it is: CVE-2025-54121 is a medium-severity denial of service vulnerability in encode starlette, published on 21 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54121 exists.

Affected packages and fixed versions:
- starlette (PyPI): affected all versions; fixed in 0.47.2
- starlette (PyPI): affected all versions; fixed in 0.47.2
- starlette (PyPI): affected all versions; fixed in 0.47.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54121/ (Markdown: https://insights.sbomify.com/CVE-2025-54121/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54121
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54121
- OSV: https://osv.dev/vulnerability/CVE-2025-54121

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54121/
Summaries are generated and may contain mistakes; the official description above is the record.
