CVE-2025-54124 XWiki Platform: Any user with editing rights can access password properties through Database List Properties
Users with editing rights can expose password hashes and other sensitive properties via database list references, requiring an upgrade to secure user credentials.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-54124?
CVE-2025-54124 is a high-severity vulnerability in Xwiki Xwiki, published on 5 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. XWiki Platform Legacy Old Core and XWiki Platform Old Core versions 9.8-rc-1 through 16.4.6, 16.5.0-rc-1 through 16.10.4, and 17.0.0-rc-1 through 17.1.0, any user with editing rights can create an XClass with a database list property that references a password property. When adding an object of that XClass, the content of that password property is displayed. In practice, with a standard rights setup, this means that any user with an account on the wiki can access password hashes of all users, and possibly other password properties (with hashed or plain storage) that are on pages that the user can view. This issue is fixed in versions 16.4.7, 16.10.5 and 17.2.0-rc-1.
Weakness: CWE-359
Which versions are affected by CVE-2025-54124?
12 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-legacy-oldcore and org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-legacy-oldcore Maven | From 16.5.0-rc-1 | 16.10.5 |
org.xwiki.platform:xwiki-platform-legacy-oldcore Maven | From 16.5.0-rc-1 | 16.10.5 |
org.xwiki.platform:xwiki-platform-legacy-oldcore Maven | From 17.0.0-rc-1 | 17.2.0-rc-1 |
org.xwiki.platform:xwiki-platform-legacy-oldcore Maven | From 17.0.0-rc-1 | 17.2.0-rc-1 |
org.xwiki.platform:xwiki-platform-legacy-oldcore Maven | From 9.8-rc-1 | 16.4.7 |
org.xwiki.platform:xwiki-platform-legacy-oldcore Maven | From 9.8-rc-1 | 16.4.7 |
6 more packages
org.xwiki.platform:xwiki-platform-oldcore Maven | From 16.5.0-rc-1 | 16.10.5 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 16.5.0-rc-1 | 16.10.5 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 17.0.0-rc-1 | 17.2.0-rc-1 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 17.0.0-rc-1 | 17.2.0-rc-1 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 9.8-rc-1 | 16.4.7 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 9.8-rc-1 | 16.4.7 |
Products include Xwiki Xwiki.
How do I fix CVE-2025-54124?
Upgrade org.xwiki.platform:xwiki-platform-legacy-oldcore to a fixed version for your release line: 16.10.5, 17.2.0-rc-1 or 16.4.7.
Is CVE-2025-54124 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54124 exists.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-r38m-cgpg-qj69.