# CVE-2025-54124: XWiki Platform: Any user with editing rights can access password properties through Database List Properties

> Users with editing rights can expose password hashes and other sensitive properties via database list references, requiring an upgrade to secure user credentials.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Aug 2025
- **Updated:** 6 Aug 2025
- **Also known as:** GHSA-r38m-cgpg-qj69

## What is CVE-2025-54124?

CVE-2025-54124 is a high-severity vulnerability in Xwiki Xwiki, published on 5 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. XWiki Platform Legacy Old Core and XWiki Platform Old Core versions 9.8-rc-1 through 16.4.6, 16.5.0-rc-1 through 16.10.4, and 17.0.0-rc-1 through 17.1.0, any user with editing rights can create an XClass with a database list property that references a password property. When adding an object of that XClass, the content of that password property is displayed. In practice, with a standard rights setup, this means that any user with an account on the wiki can access password hashes of all users, and possibly other password properties (with hashed or plain storage) that are on pages that the user can view. This issue is fixed in versions 16.4.7, 16.10.5 and 17.2.0-rc-1.

Weakness: CWE-359 (Exposure of Private Personal Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-54124?

12 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-legacy-oldcore and org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-legacy-oldcore` | Maven | From 16.5.0-rc-1 | 16.10.5 |
| `org.xwiki.platform:xwiki-platform-legacy-oldcore` | Maven | From 16.5.0-rc-1 | 16.10.5 |
| `org.xwiki.platform:xwiki-platform-legacy-oldcore` | Maven | From 17.0.0-rc-1 | 17.2.0-rc-1 |
| `org.xwiki.platform:xwiki-platform-legacy-oldcore` | Maven | From 17.0.0-rc-1 | 17.2.0-rc-1 |
| `org.xwiki.platform:xwiki-platform-legacy-oldcore` | Maven | From 9.8-rc-1 | 16.4.7 |
| `org.xwiki.platform:xwiki-platform-legacy-oldcore` | Maven | From 9.8-rc-1 | 16.4.7 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 16.5.0-rc-1 | 16.10.5 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 16.5.0-rc-1 | 16.10.5 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 17.0.0-rc-1 | 17.2.0-rc-1 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 17.0.0-rc-1 | 17.2.0-rc-1 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 9.8-rc-1 | 16.4.7 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 9.8-rc-1 | 16.4.7 |

Products: Xwiki Xwiki.

## How do I fix CVE-2025-54124?

Upgrade org.xwiki.platform:xwiki-platform-legacy-oldcore to a fixed version for your release line: 16.10.5, 17.2.0-rc-1 or 16.4.7.

## Is CVE-2025-54124 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54124 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54124 and fix it if it is affected.

What it is: CVE-2025-54124 is a high-severity vulnerability in Xwiki Xwiki, published on 5 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54124 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-legacy-oldcore (Maven): affected from 16.5.0-rc-1; fixed in 16.10.5
- org.xwiki.platform:xwiki-platform-legacy-oldcore (Maven): affected from 16.5.0-rc-1; fixed in 16.10.5
- org.xwiki.platform:xwiki-platform-legacy-oldcore (Maven): affected from 17.0.0-rc-1; fixed in 17.2.0-rc-1
- org.xwiki.platform:xwiki-platform-legacy-oldcore (Maven): affected from 17.0.0-rc-1; fixed in 17.2.0-rc-1
- org.xwiki.platform:xwiki-platform-legacy-oldcore (Maven): affected from 9.8-rc-1; fixed in 16.4.7
- org.xwiki.platform:xwiki-platform-legacy-oldcore (Maven): affected from 9.8-rc-1; fixed in 16.4.7
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 16.5.0-rc-1; fixed in 16.10.5
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 16.5.0-rc-1; fixed in 16.10.5
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 17.0.0-rc-1; fixed in 17.2.0-rc-1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 17.0.0-rc-1; fixed in 17.2.0-rc-1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 9.8-rc-1; fixed in 16.4.7
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 9.8-rc-1; fixed in 16.4.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54124/ (Markdown: https://insights.sbomify.com/CVE-2025-54124/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54124
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54124
- OSV: https://osv.dev/vulnerability/CVE-2025-54124

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54124/
Summaries are generated and may contain mistakes; the official description above is the record.
