CVE-2025-54125 XWiki Platform: Password and email exposure in xml.vm fields
Attackers with view rights can expose sensitive password and email properties via XML export, requiring an upgrade or template deletion.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-54125?
CVE-2025-54125 is a high-severity vulnerability in Xwiki Xwiki, published on 5 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. XWiki Platform Legacy Old Core and XWiki Platform Old Core versions 1.1 through 16.4.6, 16.5.0-rc-1 through 16.10.4 and 17.0.0-rc-1 through 17.1.0, the XML export of a page in XWiki that can be triggered by any user with view rights on a page by appending ?xpage=xml to the URL includes password and email properties stored on a document that aren't named password or email. This is fixed in versions 16.4.7, 16.10.5 and 17.2.0-rc-1. To work around this issue, the file templates/xml.vm in the deployed WAR can be deleted if the XML isn't needed. There isn't any feature in XWiki itself that depends on the XML export.
Weakness: CWE-359
Which versions are affected by CVE-2025-54125?
12 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-legacy-oldcore and org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-legacy-oldcore Maven | From 1.1 | 16.4.7 |
org.xwiki.platform:xwiki-platform-legacy-oldcore Maven | From 1.1 | 16.4.7 |
org.xwiki.platform:xwiki-platform-legacy-oldcore Maven | From 16.5.0-rc-1 | 16.10.5 |
org.xwiki.platform:xwiki-platform-legacy-oldcore Maven | From 16.5.0-rc-1 | 16.10.5 |
org.xwiki.platform:xwiki-platform-legacy-oldcore Maven | From 17.0.0-rc-1 | 17.2.0-rc-1 |
org.xwiki.platform:xwiki-platform-legacy-oldcore Maven | From 17.0.0-rc-1 | 17.2.0-rc-1 |
6 more packages
org.xwiki.platform:xwiki-platform-oldcore Maven | From 1.1 | 16.4.7 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 1.1 | 16.4.7 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 16.5.0-rc-1 | 16.10.5 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 16.5.0-rc-1 | 16.10.5 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 17.0.0-rc-1 | 17.2.0-rc-1 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 17.0.0-rc-1 | 17.2.0-rc-1 |
Products include Xwiki Xwiki.
How do I fix CVE-2025-54125?
Upgrade org.xwiki.platform:xwiki-platform-legacy-oldcore to a fixed version for your release line: 16.4.7, 16.10.5 or 17.2.0-rc-1.
Is CVE-2025-54125 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54125 exists.
Public exploit code: 1 Nuclei template.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-57q2-6cp4-9mq3.