# CVE-2025-54125: XWiki Platform: Password and email exposure in xml.vm fields

> Attackers with view rights can expose sensitive password and email properties via XML export, requiring an upgrade or template deletion.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Aug 2025
- **Updated:** 6 Aug 2025
- **Also known as:** GHSA-57q2-6cp4-9mq3

## What is CVE-2025-54125?

CVE-2025-54125 is a high-severity vulnerability in Xwiki Xwiki, published on 5 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. XWiki Platform Legacy Old Core and XWiki Platform Old Core versions 1.1 through 16.4.6, 16.5.0-rc-1 through 16.10.4 and 17.0.0-rc-1 through 17.1.0, the XML export of a page in XWiki that can be triggered by any user with view rights on a page by appending ?xpage=xml to the URL includes password and email properties stored on a document that aren't named password or email. This is fixed in versions 16.4.7, 16.10.5 and 17.2.0-rc-1. To work around this issue, the file templates/xml.vm in the deployed WAR can be deleted if the XML isn't needed. There isn't any feature in XWiki itself that depends on the XML export.

Weakness: CWE-359 (Exposure of Private Personal Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-54125?

12 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-legacy-oldcore and org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-legacy-oldcore` | Maven | From 1.1 | 16.4.7 |
| `org.xwiki.platform:xwiki-platform-legacy-oldcore` | Maven | From 1.1 | 16.4.7 |
| `org.xwiki.platform:xwiki-platform-legacy-oldcore` | Maven | From 16.5.0-rc-1 | 16.10.5 |
| `org.xwiki.platform:xwiki-platform-legacy-oldcore` | Maven | From 16.5.0-rc-1 | 16.10.5 |
| `org.xwiki.platform:xwiki-platform-legacy-oldcore` | Maven | From 17.0.0-rc-1 | 17.2.0-rc-1 |
| `org.xwiki.platform:xwiki-platform-legacy-oldcore` | Maven | From 17.0.0-rc-1 | 17.2.0-rc-1 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 1.1 | 16.4.7 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 1.1 | 16.4.7 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 16.5.0-rc-1 | 16.10.5 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 16.5.0-rc-1 | 16.10.5 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 17.0.0-rc-1 | 17.2.0-rc-1 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 17.0.0-rc-1 | 17.2.0-rc-1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2025-54125?

Upgrade org.xwiki.platform:xwiki-platform-legacy-oldcore to a fixed version for your release line: 16.4.7, 16.10.5 or 17.2.0-rc-1.

## Is CVE-2025-54125 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54125 exists.

Public exploit code:

- XWiki XML View - Sensitive Information Exposure (nuclei): http/cves/2025/CVE-2025-54125.yaml

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54125 and fix it if it is affected.

What it is: CVE-2025-54125 is a high-severity vulnerability in Xwiki Xwiki, published on 5 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54125 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-legacy-oldcore (Maven): affected from 1.1; fixed in 16.4.7
- org.xwiki.platform:xwiki-platform-legacy-oldcore (Maven): affected from 1.1; fixed in 16.4.7
- org.xwiki.platform:xwiki-platform-legacy-oldcore (Maven): affected from 16.5.0-rc-1; fixed in 16.10.5
- org.xwiki.platform:xwiki-platform-legacy-oldcore (Maven): affected from 16.5.0-rc-1; fixed in 16.10.5
- org.xwiki.platform:xwiki-platform-legacy-oldcore (Maven): affected from 17.0.0-rc-1; fixed in 17.2.0-rc-1
- org.xwiki.platform:xwiki-platform-legacy-oldcore (Maven): affected from 17.0.0-rc-1; fixed in 17.2.0-rc-1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 1.1; fixed in 16.4.7
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 1.1; fixed in 16.4.7
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 16.5.0-rc-1; fixed in 16.10.5
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 16.5.0-rc-1; fixed in 16.10.5
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 17.0.0-rc-1; fixed in 17.2.0-rc-1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 17.0.0-rc-1; fixed in 17.2.0-rc-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54125/ (Markdown: https://insights.sbomify.com/CVE-2025-54125/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54125
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54125
- OSV: https://osv.dev/vulnerability/CVE-2025-54125

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54125/
Summaries are generated and may contain mistakes; the official description above is the record.
