CVE-2025-54127 HAXcms's Insecure Default Configuration Leads to Unauthenticated Access

Critical 9.3 Published Updated

HAXcms Node.js backend allows unauthenticated access due to insecure default settings, enabling attackers to bypass authentication and read data.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-54127?

CVE-2025-54127 is a critical vulnerability in haxtheweb issues, published on 21 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

HAXcms with nodejs backend allows users to start the server in any HAXsite or HAXcms instance. In versions 11.0.6 and below, the NodeJS version of HAXcms uses an insecure default configuration designed for local development. The default configuration does not perform authorization or authentication checks. If a user were to deploy haxcms-nodejs without modifying the default settings, ‘HAXCMS_DISABLE_JWT_CHECKS‘ would be set to ‘true‘ and their deployment would lack session authentication. This is fixed in version 11.0.7.

Weakness: CWE-1188

Which versions are affected by CVE-2025-54127?

2 open source packages ship an affected version, including @haxtheweb/haxcms-nodejs. It affects 1 product.

PackageAffectedFixed in
@haxtheweb/haxcms-nodejs npmAll versions11.0.7
@haxtheweb/haxcms-nodejs npmAll versions11.0.7

Products include Psu Haxcms-Nodejs.

How do I fix CVE-2025-54127?

Upgrade @haxtheweb/haxcms-nodejs to 11.0.7 or later.

Is CVE-2025-54127 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54127 exists.

Sources

Also known as GHSA-f38f-jvqj-mfg6.

Is CVE-2025-54127 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free