# CVE-2025-54127: HAXcms's Insecure Default Configuration Leads to Unauthenticated Access

> HAXcms Node.js backend allows unauthenticated access due to insecure default settings, enabling attackers to bypass authentication and read data.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jul 2025
- **Updated:** 22 Jul 2025
- **Also known as:** GHSA-f38f-jvqj-mfg6

## What is CVE-2025-54127?

CVE-2025-54127 is a critical vulnerability in haxtheweb issues, published on 21 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HAXcms with nodejs backend allows users to start the server in any HAXsite or HAXcms instance. In versions 11.0.6 and below, the NodeJS version of HAXcms uses an insecure default configuration designed for local development. The default configuration does not perform authorization or authentication checks. If a user were to deploy haxcms-nodejs without modifying the default settings, ‘HAXCMS_DISABLE_JWT_CHECKS‘ would be set to ‘true‘ and their deployment would lack session authentication. This is fixed in version 11.0.7.

Weakness: CWE-1188 (Initialization of a Resource with an Insecure Default)

## Which versions are affected by CVE-2025-54127?

2 open source packages ship an affected version, including @haxtheweb/haxcms-nodejs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@haxtheweb/haxcms-nodejs` | npm | All versions | 11.0.7 |
| `@haxtheweb/haxcms-nodejs` | npm | All versions | 11.0.7 |

Products: Psu Haxcms-Nodejs.

## How do I fix CVE-2025-54127?

Upgrade @haxtheweb/haxcms-nodejs to 11.0.7 or later.

## Is CVE-2025-54127 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54127 exists.

## Other vulnerabilities in haxtheweb issues

- [CVE-2025-49141](https://insights.sbomify.com/CVE-2025-49141/): HaxCMS-PHP Command Injection Vulnerability (high 8.6)
- [CVE-2025-49137](https://insights.sbomify.com/CVE-2025-49137/): Hax CMS Stored Cross-Site Scripting vulnerability (high 8.5)
- [CVE-2025-54378](https://insights.sbomify.com/CVE-2025-54378/): HAX CMS Backend Lacks Comprehensive Authorization Checks (high 8.3)
- [CVE-2026-22704](https://insights.sbomify.com/CVE-2026-22704/): HAXcms Has Stored XSS Vulnerability that May Lead to Account Takeover (high 8.1)
- [CVE-2025-54137](https://insights.sbomify.com/CVE-2025-54137/): NodeJS version of the HAX CMS application is distributed with Default Secrets (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54127 and fix it if it is affected.

What it is: CVE-2025-54127 is a critical vulnerability in haxtheweb issues, published on 21 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54127 exists.

Affected packages and fixed versions:
- @haxtheweb/haxcms-nodejs (npm): affected all versions; fixed in 11.0.7
- @haxtheweb/haxcms-nodejs (npm): affected all versions; fixed in 11.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54127/ (Markdown: https://insights.sbomify.com/CVE-2025-54127/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54127
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54127
- OSV: https://osv.dev/vulnerability/CVE-2025-54127

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54127/
Summaries are generated and may contain mistakes; the official description above is the record.
