{"answers":{"affected":"2 open source packages ship an affected version, including @haxtheweb/haxcms-nodejs. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54128 exists.","fix":"Upgrade @haxtheweb/haxcms-nodejs to 11.0.8 or later.","what":"CVE-2025-54128 is a high-severity cross-site scripting vulnerability in haxtheweb issues, published on 21 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-54128 and fix it if it is affected.\n\nWhat it is: CVE-2025-54128 is a high-severity cross-site scripting vulnerability in haxtheweb issues, published on 21 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54128 exists.\n\nAffected packages and fixed versions:\n- @haxtheweb/haxcms-nodejs (npm): affected all versions; fixed in 11.0.8\n- @haxtheweb/haxcms-nodejs (npm): affected all versions; fixed in 11.0.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-54128/ (Markdown: https://insights.sbomify.com/CVE-2025-54128/index.md)","id":"CVE-2025-54128","markdown":"https://insights.sbomify.com/CVE-2025-54128/index.md","name":"CVE-2025-54128","record":{"aliases":["GHSA-59g8-h59f-8hjp"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"HAX CMS Node.js","requires_auth":"none","summary":"Attackers can execute arbitrary scripts due to disabled Content Security Policy in HAX CMS Node.js backend, requiring an upgrade to secure production environments.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"haxcms-nodejs","vendor":"psu"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:H/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"HAX CMS NodeJs allows users to manage their microsite universe with a NodeJs backend. In versions 11.0.7 and below, the NodeJS version of HAX CMS has a disabled Content Security Policy (CSP). This configuration is insecure for a production application because it does not protect against cross-site-scripting attacks. The contentSecurityPolicy value is explicitly disabled in the application's Helmet configuration in app.js. This is fixed in version 11.0.8.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"HAX CMS NodeJs's Disabled Content Security Policy Enables Cross-Site Scripting","id":"CVE-2025-54128","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"HAXiam allows for User Enumeration","id":"CVE-2025-54129"},"packages":[{"ecosystem":"npm","fixed":["11.0.8"],"introduced":["0"],"last_affected":[],"package":"@haxtheweb/haxcms-nodejs","purl":null,"source":"GHSA-59g8-h59f-8hjp"},{"ecosystem":"npm","fixed":["11.0.8"],"introduced":["0"],"last_affected":[],"package":"@haxtheweb/haxcms-nodejs","purl":"pkg:npm/%40haxtheweb/haxcms-nodejs","source":"GHSA-59g8-h59f-8hjp"}],"prev":{"headline":"HAXcms's Insecure Default Configuration Leads to Unauthenticated Access","id":"CVE-2025-54127"},"products":["issues"],"published":"2025-07-21","related":[{"cvss_score":9.3,"headline":"HAXcms's Insecure Default Configuration Leads to Unauthenticated Access","id":"CVE-2025-54127","kev_date_added":null,"published":"2025-07-21"},{"cvss_score":8.6,"headline":"HaxCMS-PHP Command Injection Vulnerability","id":"CVE-2025-49141","kev_date_added":null,"published":"2025-06-09"},{"cvss_score":8.5,"headline":"Hax CMS Stored Cross-Site Scripting vulnerability","id":"CVE-2025-49137","kev_date_added":null,"published":"2025-06-09"},{"cvss_score":8.3,"headline":"HAX CMS Backend Lacks Comprehensive Authorization Checks","id":"CVE-2025-54378","kev_date_added":null,"published":"2025-07-26"},{"cvss_score":8.1,"headline":"HAXcms Has Stored XSS Vulnerability that May Lead to Account Takeover","id":"CVE-2026-22704","kev_date_added":null,"published":"2026-01-10"},{"cvss_score":7.3,"headline":"NodeJS version of the HAX CMS application is distributed with Default Secrets","id":"CVE-2025-54137","kev_date_added":null,"published":"2025-07-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-07-22","vendors":["haxtheweb"]},"summary":"Attackers can execute arbitrary scripts due to disabled Content Security Policy in HAX CMS Node.js backend, requiring an upgrade to secure production environments.","url":"https://insights.sbomify.com/CVE-2025-54128/"}