# CVE-2025-54128: HAX CMS NodeJs's Disabled Content Security Policy Enables Cross-Site Scripting

> Attackers can execute arbitrary scripts due to disabled Content Security Policy in HAX CMS Node.js backend, requiring an upgrade to secure production environments.

- **Severity:** High 7.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:H/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Jul 2025
- **Updated:** 22 Jul 2025
- **Also known as:** GHSA-59g8-h59f-8hjp

## What is CVE-2025-54128?

CVE-2025-54128 is a high-severity cross-site scripting vulnerability in haxtheweb issues, published on 21 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

HAX CMS NodeJs allows users to manage their microsite universe with a NodeJs backend. In versions 11.0.7 and below, the NodeJS version of HAX CMS has a disabled Content Security Policy (CSP). This configuration is insecure for a production application because it does not protect against cross-site-scripting attacks. The contentSecurityPolicy value is explicitly disabled in the application's Helmet configuration in app.js. This is fixed in version 11.0.8.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-54128?

2 open source packages ship an affected version, including @haxtheweb/haxcms-nodejs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@haxtheweb/haxcms-nodejs` | npm | All versions | 11.0.8 |
| `@haxtheweb/haxcms-nodejs` | npm | All versions | 11.0.8 |

Products: Psu Haxcms-Nodejs.

## How do I fix CVE-2025-54128?

Upgrade @haxtheweb/haxcms-nodejs to 11.0.8 or later.

## Is CVE-2025-54128 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54128 exists.

## Other vulnerabilities in haxtheweb issues

- [CVE-2025-54127](https://insights.sbomify.com/CVE-2025-54127/): HAXcms's Insecure Default Configuration Leads to Unauthenticated Access (critical 9.3)
- [CVE-2025-49141](https://insights.sbomify.com/CVE-2025-49141/): HaxCMS-PHP Command Injection Vulnerability (high 8.6)
- [CVE-2025-49137](https://insights.sbomify.com/CVE-2025-49137/): Hax CMS Stored Cross-Site Scripting vulnerability (high 8.5)
- [CVE-2025-54378](https://insights.sbomify.com/CVE-2025-54378/): HAX CMS Backend Lacks Comprehensive Authorization Checks (high 8.3)
- [CVE-2026-22704](https://insights.sbomify.com/CVE-2026-22704/): HAXcms Has Stored XSS Vulnerability that May Lead to Account Takeover (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54128 and fix it if it is affected.

What it is: CVE-2025-54128 is a high-severity cross-site scripting vulnerability in haxtheweb issues, published on 21 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54128 exists.

Affected packages and fixed versions:
- @haxtheweb/haxcms-nodejs (npm): affected all versions; fixed in 11.0.8
- @haxtheweb/haxcms-nodejs (npm): affected all versions; fixed in 11.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54128/ (Markdown: https://insights.sbomify.com/CVE-2025-54128/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54128
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54128
- OSV: https://osv.dev/vulnerability/CVE-2025-54128

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54128/
Summaries are generated and may contain mistakes; the official description above is the record.
