# CVE-2025-54129: HAXiam allows for User Enumeration

> An authenticated attacker can enumerate valid user accounts by observing HTTP response codes, facilitating targeted attacks against the HAXiam platform.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 21 Jul 2025
- **Updated:** 22 Jul 2025

## What is CVE-2025-54129?

CVE-2025-54129 is a medium-severity vulnerability in haxtheweb issues, published on 21 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

HAXiam is a packaging wrapper for HAXcms which allows anyone to spawn their own microsite management platform. In versions 11.0.4 and below, the application returns a 200 response when requesting the data of a valid user and a 404 response when requesting the data of an invalid user. This can be used to infer the existence of valid user accounts. An authenticated attacker can use automated tooling to brute force potential usernames and use the application's response to identify valid accounts. This can be used in conjunction with other vulnerabilities, such as the lack of authorization checks, to enumerate and deface another user's sites. This is fixed in version 11.0.5.

Weakness: CWE-204 (Observable Response Discrepancy)

## Which versions are affected by CVE-2025-54129?

It affects 1 product.


Products: Psu Haxiam.

## How do I fix CVE-2025-54129?

No fix has been published for CVE-2025-54129 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-54129 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54129 exists.

## Other vulnerabilities in haxtheweb issues

- [CVE-2026-35185](https://insights.sbomify.com/CVE-2026-35185/): HAX CMS's public /server-status endpoint exposes authentication tokens, user activity, and client IP addresses (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54129 and fix it if it is affected.

What it is: CVE-2025-54129 is a medium-severity vulnerability in haxtheweb issues, published on 21 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54129 exists.

Affected product: haxtheweb issues. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54129/ (Markdown: https://insights.sbomify.com/CVE-2025-54129/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54129
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54129
- OSV: https://osv.dev/vulnerability/CVE-2025-54129

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54129/
Summaries are generated and may contain mistakes; the official description above is the record.
