CVE-2025-54134 HAX CMS NodeJs's Improper Error Handling Leads to Denial of Service

High 7.1 Published Updated

An authenticated attacker can crash the HAX CMS NodeJS application by sending API requests with missing URL parameters, causing a denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-54134?

CVE-2025-54134 is a high-severity denial of service vulnerability in haxtheweb issues, published on 21 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

HAX CMS NodeJs allows users to manage their microsite universe with a NodeJs backend. In versions 11.0.8 and below, the HAX CMS NodeJS application crashes when an authenticated attacker provides an API request lacking required URL parameters. This vulnerability affects the listFiles and saveFiles endpoints. This vulnerability exists because the application does not properly handle exceptions which occur as a result of changes to user-modifiable URL parameters. This is fixed in version 11.0.9.

Weakness: CWE-703, CWE-248, CWE-20

Which versions are affected by CVE-2025-54134?

2 open source packages ship an affected version, including @haxtheweb/haxcms-nodejs. It affects 1 product.

PackageAffectedFixed in
@haxtheweb/haxcms-nodejs npmAll versions11.0.9
@haxtheweb/haxcms-nodejs npmAll versions11.0.9

Products include Psu Haxcms-Nodejs.

How do I fix CVE-2025-54134?

Upgrade @haxtheweb/haxcms-nodejs to 11.0.9 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-54134 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54134 exists.

Sources

Also known as GHSA-pjj3-j5j6-qj27.

Is CVE-2025-54134 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free