# CVE-2025-54134: HAX CMS NodeJs's Improper Error Handling Leads to Denial of Service

> An authenticated attacker can crash the HAX CMS NodeJS application by sending API requests with missing URL parameters, causing a denial of service.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jul 2025
- **Updated:** 23 Jul 2025
- **Also known as:** GHSA-pjj3-j5j6-qj27

## What is CVE-2025-54134?

CVE-2025-54134 is a high-severity denial of service vulnerability in haxtheweb issues, published on 21 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

HAX CMS NodeJs allows users to manage their microsite universe with a NodeJs backend. In versions 11.0.8 and below, the HAX CMS NodeJS application crashes when an authenticated attacker provides an API request lacking required URL parameters. This vulnerability affects the listFiles and saveFiles endpoints. This vulnerability exists because the application does not properly handle exceptions which occur as a result of changes to user-modifiable URL parameters. This is fixed in version 11.0.9.

Weakness: CWE-703 (Improper Check or Handling of Exceptional Conditions), CWE-248 (Uncaught Exception), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-54134?

2 open source packages ship an affected version, including @haxtheweb/haxcms-nodejs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@haxtheweb/haxcms-nodejs` | npm | All versions | 11.0.9 |
| `@haxtheweb/haxcms-nodejs` | npm | All versions | 11.0.9 |

Products: Psu Haxcms-Nodejs.

## How do I fix CVE-2025-54134?

Upgrade @haxtheweb/haxcms-nodejs to 11.0.9 or later.

## Is CVE-2025-54134 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54134 exists.

## Other vulnerabilities in haxtheweb issues

- [CVE-2025-54127](https://insights.sbomify.com/CVE-2025-54127/): HAXcms's Insecure Default Configuration Leads to Unauthenticated Access (critical 9.3)
- [CVE-2025-49141](https://insights.sbomify.com/CVE-2025-49141/): HaxCMS-PHP Command Injection Vulnerability (high 8.6)
- [CVE-2025-49137](https://insights.sbomify.com/CVE-2025-49137/): Hax CMS Stored Cross-Site Scripting vulnerability (high 8.5)
- [CVE-2025-54378](https://insights.sbomify.com/CVE-2025-54378/): HAX CMS Backend Lacks Comprehensive Authorization Checks (high 8.3)
- [CVE-2026-22704](https://insights.sbomify.com/CVE-2026-22704/): HAXcms Has Stored XSS Vulnerability that May Lead to Account Takeover (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-54134 and fix it if it is affected.

What it is: CVE-2025-54134 is a high-severity denial of service vulnerability in haxtheweb issues, published on 21 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-54134 exists.

Affected packages and fixed versions:
- @haxtheweb/haxcms-nodejs (npm): affected all versions; fixed in 11.0.9
- @haxtheweb/haxcms-nodejs (npm): affected all versions; fixed in 11.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-54134/ (Markdown: https://insights.sbomify.com/CVE-2025-54134/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-54134
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-54134
- OSV: https://osv.dev/vulnerability/CVE-2025-54134

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-54134/
Summaries are generated and may contain mistakes; the official description above is the record.
